I am used to doing this in Windows with FireFox or IE by pressing Ctrl+F5.

Is there a way to do this for Safari on a Mac?


Go to Safari > Empty Cache, or hit ⌘ Command+⌥ Option+E. To refresh, click the refresh button on the addressbar or press ⌘ Command+R.

Another tip. If you want to restore Safari, like completely clear all the caches, or parts of it, go to Safari > Reset Safari. I use it usually when I need to clear a lot of memory from Safari, for it will clear the webpage screenshots, the cookies, the favicons, etc.

Edit: On the latest version of Empty Cache isn't on the Safari menu any more. It's now on the Develop menu. To show the Develop menu it, go to Safari > Preferences..., click the Advanced tab, and check Show Develop menu in menu bar. The keyboard shortcut remains unchanged, though.

Safari > Reset Safari isn't an option any more. To clear history you can use History > Clear History... and to clear cookies/local storage data, go to Safari > Preferences..., click the Privacy tab, and either click Remove All Website Data... or Details... to view and remove it for individual sites.

| improve this answer | |
  • What can be done on an iPad or iPhone Safari? – Csaba Toth Jul 25 '17 at 15:36

⇧ Shift and clicking the Refresh button generally does a full refresh. You can also empty cache with ⌘ Command+E, and then refresh.

| improve this answer | |
  • I appreciate your answer as it solved my issue. – NullPointer Jun 10 '14 at 12:36
  • @NullPointer great to hear it! – ConstantineK Jun 10 '14 at 17:01
  • 1
    The command sequence for that should be Cmd + Shift + R. As described here: dotjay.co.uk/2007/05/hard-refresh-firefox-mac – David Jun 20 '14 at 22:35
  • I really need this solution to work, but it doesn't. I'm looking at a css file at url ending style.css?ver=1.0 If I view this URL in chrome, or with wget, it's showing the restored version, but safari is refusing to refresh. If I change the URL in any way then it refreshes but that's no use to me. So now I'm left trying to figure out how to backup my saved passwords so I can try the 'Remove All Website Data...' nuclear option. All this so that safari will lose its cache on one poxy little css file. Infuriating! – Harry Wood Dec 13 '16 at 13:16
  • While looking into it yesterday I came across a couple of other ideas which I'll stick here: RichardF suggests "open resource (alone) in a new window, shift-cmd-R, then go back to first window and shift-cmd-R" . Mathias Bynens suggests "focus the Web Developer Tools while performing the keyboard combo" I can't confirm whether those would fix it for me, because when I came back after lunch the problem had gone away. – Harry Wood Dec 14 '16 at 14:57

If you haven't already, enable developer tools: open settings (Cmd + ,), go to the advanced tab, and check the box that says "Show Develop menu in menu bar."

Empty caches a single time: Develop > Empty Caches

Keyboard shortcut to empty caches a single time: Opt + Cmd + E

If you want to disable caching (for example, if you are developing a website and need to consistently reload changes to files on your site) you can do so: Develop > Disable Caches. Select this option again to reenable caching.

Note: for Safari 11 the disable caching feature was moved to the Network section of the web inspector. Open the web inspector with Cmd + Shift + I, go to the Network tab, and click the icon on the far right that looks like this:

disable caches button

| improve this answer | |
  • There is no Disable Caches option on safari 11. – Noishe Oct 12 '17 at 17:38
  • @Noishe this option is still there, but it moved. See my updated answer. – intcreator Oct 13 '17 at 1:21
  • Now if only it was available while debugging mobile! – Noishe Oct 13 '17 at 21:36
  • @Noishe under the Develop menu you should be able to use the options "Enter Responsive Design Mode" and "User Agent" to debug the mobile view of your application. If you open the web inspector the button should still be there. – intcreator Oct 13 '17 at 21:42
  • I wish I could trust the idiosyncrasies of individual platforms to an emulated version, but alas, I've been bitten by that before and can not. – Noishe Oct 17 '17 at 19:30

You must click References->Advanced->check to Show develop menu in menu bar. Later in Inspect Element press ShiftCmdR.

Note: Your mouse must click into the element within "Elements tab", then you can press Shift+Cmd+R.

enter image description here

| improve this answer | |
  • It's just command⌘ + R nowadays (Safari 14). The trick being to open the Web Inspector (option⌥ + command⌘ + I) before triggering a refresh. – Cœur Jul 14 at 12:09

on Safari version Version 11.1.2 (13605.3.8), it seems to be Opt+Cmd+E.

You can check by open up Develop menu on top > look for Empty Caches item on the drop down list > see what the shortcut is.

| improve this answer | |

+ + R

Tested in Safari Version 12.0.1 (14606.

| improve this answer | |

⌘ Command⌥ OptionR

This is the correct answer for people looking for Safari's equivalent for ⌘ Command⇧ ShiftR in Chrome. This works for both Safari and the Web Inspector when connected to an iPad/iPhone.

Keep in mind this does not clear cache, it simply does a "Hard Refresh".

| improve this answer | |
  • This is the correct answer. The OP isn't asking for clearing caches, but doing a hard refresh, which is what Ctrl-F5 does on a Windows browser. – cjbarth Mar 15 '19 at 13:58

On Develop Menu If Develop Menu not show in your bar, setting it on Safari→Preferences→Advanced and check in "Show Develop menu in menu bar"

Or, you can press ⌥ Option ⌘ Command E

| improve this answer | |

If you are use safari browser in windows, then ctrl + alt + e use for empty cache.

| improve this answer | |
  • 3
    No-one should still be using Safari on Windows. It was last updated in 2012. – Tetsujin Sep 4 '18 at 8:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .