62

TextEdit in Mavericks changes the standard double quotes "Hello" to using curly, non-ascii quotation marks “Hello”. It does this even when you edit plain text documents. Is there a way to prevent this new behavior in Mavericks?

1
  • If you're looking for a text editor, then TextEdit is the wrong tool, and has many problems and limitations. Something like BBEdit is much more suited to the task. – benwiggy Oct 9 '20 at 21:12
76

This is not just TextEdit, it's Mavericks.

Under System Preferences > Keyboard, you can change the quotation marks.

Go to the 'Text' sub-menu. On the right-hand side of the box, uncheck the "Use smart quotes and dashes" checkbox.

5
  • 11
    For those that still can't find it, more specifically: System Preferences > Keyboard > Text > Uncheck the "Use smart quotes and dashes" checkbox. – Asaph Jun 20 '14 at 17:07
  • For the ones which already have a file damaged with this little hanging worms (I mean ‟ ″), look at the answer from igaar: apple.stackexchange.com/a/171855/22003 . – dan Jul 29 '15 at 8:11
  • 6
    "Smart quotes"? More like... "Dumb quotes". – catamphetamine Feb 20 '17 at 15:21
  • @Rob, Are you sure it's the problem with the OS itself? Then why do other apps not have this problem except for Textedit>? – Pacerier Aug 6 '17 at 1:02
  • @Pacerier probably because only mac native apps rely on that behavior. Similar to how mac text autocorrect only works in safari, etc – chrismarx Jul 13 '18 at 12:36
17

The following procedure worked for me:

In TextEdit select all your text by pressing ⌘ Cmd-A and then go to Edit > Substitutions and uncheck Smart Quotes. Make sure Smart Quotes is not active and it should be solved.

2
  • 2
    This should be the correct answer. – Pacerier Aug 6 '17 at 1:02
  • Tragically Cmd + a then toggling the setting seems to do nothing to get rid of them. You have to turn it off then do a normal ` edit menu -> find+replace` to get rid of those smart quotes...after turning them off. – rogerdpack Oct 9 '20 at 16:32
2

If you already unchecked System Preferences > Keyboard > Text > Use smart quotes and dashes.

There's also a checkmark on TextEdit > Preferences > "Smart quotes" (I don't know the translation but it something like that).

Be sure to uncheck that one too.

0

I tried unchecking the Smart quotes option in both the MAC system preferences system preferences -> keyboard -> text tab untick the use smart quotes and dashes option and in textedit app preferences at textedit -> preferences -> uncheck smart quotes and dashes in rich text documents only option

But the issue was still not resolved for me. When I type single quote or double quote in rich text document then it is converted to curly quote. For example, if I do a search using command+F for the single quote then it will not find any.

The only way I was able to solve this in my MAC is that I need to use ctrl key when typing either single quote or double quote. For example, when typing single quote I need to type ctrl + singlequote and when typing double quote I need to type ctrl + shift + doublequote

I am using MAC OS Catalina and rich text document, hope someone can point to a permanent fix for this rather than remembering the keyboard shortcut each time.

1
  • Did you also check the Edit menu? – Tom Gewecke Oct 9 '20 at 16:43
0

It appears that by default, TextEdit (and other apps) inherit from the preferences -> keyboard setting.

But they only inherit from it at start time. So you can change it in preferences -> keyboard, then restart you app.

Or if you specify it within the apps Edit menu -> Substitutions -> Smart quotes then it appears to override whatever the keyboard preference is (permanently) but for just that app. So they both work.

2
  • What is you macos version? It should be included in the answer. – Tom Gewecke Oct 9 '20 at 16:42
  • Catalina, I assume it still applies for others... – rogerdpack Oct 9 '20 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .