I am trying to turn on Hardware Virtualization for my new MacBook Pro for Windows 8.1 setup using Boot Camp.

I have searched online and I know that we can not just go to the BIOS like windows and change settings. Unfortunately, most of the solution I have come across are for Parallels or VMs.

Can anyone kindly let me know how to enable Hardware Virtualization on MBP for Windows 8.1 installed using Boot Camp?


7 Answers 7


There is no hardware virtualization to turn on or off like on Wintel PCs.

That switch and many other BIOS switches are there because (at least in part) the hardware manufacturers don't make the hardware AND software, like Apple does.

It is always on in any Mac that has a processor that supports virtualization. Pretty much any Mac in the last several years does so you are good to go with this one.

  • Oh ok. Thanks. My only concern was that Visual Studio told me that the hardware virtualization was off.
    – Ahsan
    Commented Feb 9, 2014 at 5:40
  • 1
    Under task manager, there should be an field telling you if virtualization is enabled. It's in full task manager, under processor tab...
    – TiernanO
    Commented Feb 9, 2014 at 15:47
  • 10
    Wrong answer. There is no hardware virtualization to turn on or off like on Wintel PCs. is flat out wrong. Silicon features can be disabled via BIOS or UEFI - which is what's happening in Apple's broken bootcamp mode. Commented Apr 13, 2016 at 16:58
  • 3
    This answer is 100% incorrect. Macbook Bootcamp is broken and sometimes turns it off.
    – csauve
    Commented Mar 30, 2017 at 16:29
  • It answered the OPs question sufficiently. Regardless of what is or is not "broken" on BootCamp this (I assume) sufficiently an answer that he/she was happy with. I have learned in IT it is not so much about being absolutely right or wrong, it's about fixing the issue. I guess this fixed the issue. The other answers suffice to expand and enhance... Commented Apr 8, 2020 at 15:16

It sounds like you're running into the same issue I did, where after booting into Windows the VT-x shows as 'Disabled' in Task Manager.

Not sure how or why, but after going into

  • OS X
  • System Preferences
  • Target Disk
  • Select the BOOTCAMP disk as the startup disk

Everything was well after that and I could happily use Hyper-V, even from a cold boot.

If I cold booted using the Options-key, and then selecting Windows, VT-x was disabled in Task Manager.

Go figure. Could some Mac genius out there explain this one?

  • do you meant Startup or Target Disk mode in the startup panel
    – ina
    Commented Dec 5, 2014 at 0:38
  • 3
    Mac "genius" will tell you you're using an unintended software with their hardware. Honest (something Apple should search for definition) answer would be - firmware bug which apple can't properly fix since 2008 (forums.macrumors.com/showthread.php?t=821551). Commented Dec 30, 2014 at 16:09
  • 1
    It was the Startup Disk for me.
    – Jason
    Commented Aug 23, 2016 at 23:39
  • Thanks for your answer, I wasted nearly two hours before I found your answer.
    – Smartkid
    Commented Sep 26, 2016 at 13:34
  • 5
    This thread explains that you have to boot using the CSM-BIOS layer. discussions.apple.com/thread/6720461?tstart=0 ; In addition it also provides a command line to permanently fix this problem. First use diskutil list to work out Windows partition, then sudo /usr/sbin/bless --device /dev/disk0s4 --setBoot --legacy --legacydrivehint /dev/disk0
    – Chui Tey
    Commented Dec 23, 2016 at 23:10

EDIT: I found a better way to get this working instead of the boot dance originally suggested (it's below for reference). Basically set enable_and_lock_vmx true in rEFInd and that's it. Details below ...

Suggested method

  1. Disable macOS System Integrity Protection/SIP (Reboot Mac, hold down Command + R keys, at "OS X Utilities Utilities" pick "Terminal" menu item -> type in terminal csrutil disable; reboot)
  2. Back inside macOS after the reboot, get rEFInd and extract it anywhere (desktop, downloads etc)
  3. Open a terminal window, cd to where you extracted it and edit via sudo nano refind/refind.conf-sample
  4. Uncomment enable_and_lock_vmx and set to true i.e. the whole line should read enable_and_lock_vmx true. <= This is what really fixes the issue!
  5. [optional] While here, change the timeout to something quick, like 4 or 5 i.e. timeout 4
  6. Install rEFInd by running ./refind-install from terminal. The sample config you edited is used as the installed config.
  7. [optional] Enable SIP again. Follow #1 above but run csrutil enable; reboot instead

This method is very smooth - it works on normal as well as encrypted disks (FileVault2, VeraCrypt or BitLocker) and really takes a few minutes to install. Best of all, it works in every reboot.

Old method

None of the other methods worked for me, especially since my Windows 10 was Bitlocker encrypted i.e. it doesn't show up in Startup Disks to chose to reboot to. The steps below work though

  1. Power off

    Not just a hard reboot; fully powered off; as in 'count to 10 when off' off

  2. Power on and Boot to OS X desktop

    This process loads virtualization properly. In my case, I had to hold option and select OS X, enter my FileVault password (my OS X is encrypted) and then wait to boot into OS X desktop.

  3. Reboot to Windows

    Soft reboot via the Apple menu i.e. top left Apple icon => restart. During bootup select Windows/Bootcamp (via the option key). My Windows was Bitlocker encrypted, so I entered the disk password, booted to Windows, entered Windows password, landed on Windows 10 desktop. This time Hyper-V was present and functional!

I'm putting this here for future reference but I hope Apple actually fixes their Bootcamp boot process. It's been broken for 8 years now and the above hackery is ridiculous for a $3000 machine and when Bootcamp is an officially supported Mac feature.

  • 3
    PERFECT SOLUTION. Congrats 4 that. Commented Jul 4, 2017 at 15:36
  • I only have one partition with Windows 10 on my MacBook (MacBookPro11,2 - 2014 - Core i7 2.2), so I can't do the steps on OS X. Any idea on how to do this on Windows only? Commented Nov 22, 2018 at 13:38
  • Here is more detailed step-by-step instruction for newer versions of MacOS X (El Capitan in my case) dea.nbird.com.au/2017/02/24/… with some optional ways (e.g. using Windows only without MacOS)
    – Rusted
    Commented May 14, 2019 at 19:39
  • For GRUB users, adding wrmsr 0x3a 0x05 to grub.cfg achieves the same as enable_and_lock_vmx true in rEFInd. Commented Apr 19, 2020 at 5:22
  • Awesome!! Confirmed to work in Big Sur running on a mid-2015 Macbook pro Commented Dec 14, 2021 at 18:33

It seems that if you boot directly to Windows it doesn't work, but if you boot to OS X and switch to Windows, it works. Or you can boot to Windows, change to OS X and go back to Windows again.

  • This worked for me. 1. boot into OS X and I ran docker run hello-world to ensure docker was working correctly. It was 2. Restart and hold the option key to bring up the option to book into Windows 3. Select Windows. I ran docker run hello-world to ensure docker was working correctly. It was.
    – cramhead
    Commented Sep 20, 2016 at 17:49
  • This is what worked for me. It seems that the MacBook Pro needs to boot into OSX to enable virtualization. After that, a soft restart into Windows will have virtualization enabled. I have a mid-2015 15" MacBook Pro with i7 and Windows 10 Pro with Anniversary Update.
    – JohnnyO
    Commented Oct 6, 2016 at 22:05
  • I only know of cold-booting into WIN on my MAC by using the Options-key. When I instead boot to MAC first, how do I then switch to WIN on a BootCamp?
    – Mary Jane
    Commented Dec 27, 2016 at 17:50
  • 1
    On preferences, there is a boot disk section that allows you to choose a partition to boot Commented Dec 27, 2016 at 17:53

I tried with and without holding alt key down, from Mac OS to Windows and the other way.

The Hyper-V installation begins and asks for a reboot, and during starting up of windows then 2nd step of the installation failed and rolled back.

Today I bought thunderbolt to Ethernet adapter, plugged it, installed Hyper-V and after reboot I could use it. Even when I unplug the adapter.

So it seams Hyper-V need some sort of Ethernet Adapter installed.

  • 1
    The 'thunderbolt to ethernet adapter' trick for getting hyper-v to work does NOT work with an 2015 iMac + Windows 10.
    – Kyle
    Commented Jul 6, 2016 at 17:04

After I installed rEFInd to triple boot my MF839 Macbook (Win10, Ubuntu, OSX), to enable Virtualization on Windows 10, first I boot to OSX, then when it's login screen appear, I hit the restart button so the mac restart again then I choose Windows 10 from rEFInd.

  • 1
    Which mac were you using?
    – Kyle
    Commented Jul 6, 2016 at 17:05

I had tried all the various boot / reboot combinations and nothing worked until I added the Thunderbolt to Ethernet adaptor. The next time I started up the Windows Boot Camp partition I could enable Hyper V.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .