I just did a hard reset on my iPhone 4S by wiping the phone and restoring an iCloud backup. During that process, I used my iPad charger to make sure it stayed charged while it was being wiped and restored.

However, after the restore was complete and my phone was back up and running the volume control was gone. It was simply non-existent in Control Center, grayed out in Music.app, and the volume buttons didn't work. It looked like what happens when the phone is connected to a car stereo, for example. Interestingly, the ringer control in Settings -> Sounds, worked.

I have tried:

  • Rebooting the device
  • Playing music, and a video (which work through headphones, but not the speakers)
  • Tested Siri to confirm that it wasn't a hardware problem in the speakers actually malfunctioning.
  • Closed all apps, except one.
  • Tried testing sounds with an alarm app, which didn't play as well.

Any ideas on how I can fix this?

  • So you actually did a reset with the cable in the phone? Did you reboot with Homebutton + powerbutton as hard-reset or did you restore it completely using iTunes?
    – Rob
    Feb 8, 2014 at 14:11
  • @Robuust, I plugged the phone in, wiped it, and than restored using iCloud. After that, in an attempt to fix the problem I rebooted (power + home buttons) like I mentioned - so they were two separate events. The next thing I was going to try was another restore - that time solely on battery power, but didn't have to. Feb 8, 2014 at 16:13

4 Answers 4


To fix this problem, I got my iPad charger (which was disconnected from any power source such as a wall outlet), and plugged it into my iPhone, and unplugged it twice. This process fixed the iPhone.

  • 1
    Magic.....what a magical way to fix problems.
    – Ruskes
    Feb 8, 2014 at 14:28

I had the same exact problem with iPhone 4s. Plugged my iPad charger in and unplugged twice and the volume worked again!!!!

Very weird, but cool at the same time.


A toothbrush cleaning the space where the charger plugs in to the iPhone will also solve this problem.


Try adding few drops of water, i had the same problem , and so i added a two to three drops of water both in the headphone jack and the charging slot, nd ta da da! It started working BUT dry it really quick before it hits the internal parts of your phone!

  • I wouldn't recommend this - there is a water sensor in the headphone port which could void your warranty if it turns red. Instead, I'd recommend cleaning the port with a toothpick or tiny brush. Apr 3, 2015 at 20:28
  • Bringing together water and electronic devices is a horrible idea. Apart from the danger of breaking something, this will void warrenty, Apple has humidity indicators in the phones.
    – Jens Erat
    Apr 3, 2015 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .