0

I installed Windows 8 on my macbook pro (Item No : 8899069, Mftr Part No : MD313LL/A) via boot camp. I installed the boot camp support tools. The wifi adapter says that it is working correctly. However, when I go into the control panel, the wifi adapter is not enabled. When I try to enable it, it says "enabling...", but then goes away. It's not enabled afterwards.

I tried to uninstall the driver, and then repair the support tools. No luck.

I followed these directions, with no luck. I also tried to run setup.exe from these drivers, with no luck. Last, I tried to run setup.exe in compatibility mode, with no luck.

Has anyone been able to get the macbook wifi enabled in Windows 8? It reminds me of a time when I couldn't get my wifi card to work, and then I realized I didn't press the 'enable wifi' button on my pc.

I don't even see an error in the event viewer :(

Has anyone been able to get wifi to work in windows 8?

EDIT: The network card is a Broadcom 802.11n network adapter (as per the device manager)

  • Side question: Why does the boot camp select drive menu also have a drop down for wireless networks? – Hoppe Feb 18 '14 at 20:26
  • The answer to the side question is that you can reinstall OSX via wifi from the boot menu, and this is an interface to connect to secured wireless connections. – wrossmck Feb 23 '14 at 19:27
0

Try to install the Windows 8.1 driver from this website: Link (or here you have the Download Link directly: download).

One solution would be:

  1. Boot into OS X
  2. Select Windows as primary boot partition
  3. Restart your Mac (it should boot now directly into Windows)
  4. Restart Windows (NOT turning off. Start > Restart)

Second suggestion:

  1. Uninstall the driver completely
  2. Restart into OS X
  3. Then restart into Windows

Sometimes the WiFi driver is working after a few minutes. If not: Install the driver from above (from the Download link).

It has something to do with Bootcamp and Mac. This isn't a Windows problem. The driver isn't loading properly. Maybe Apple is going to fix this.

  • I didn't have luck with this unfortunately. The drivers you linked to wouldn't install successfully. And the device is still disabled after following these steps. – Hoppe Feb 18 '14 at 20:24
0

I bought an Edimax wireless card to see if it resolved the problem, but I had similar issues.

As per Edimax support:

  1. Please uninstall ZoneAlarm
  2. Reboot your computer
  3. Then you can enable the wireless network connection
  4. After the wireless is working properly, you can re-install ZoneAlarm back.

I've tested steps 1-3, and now both the built in wifi and the edimax card work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .