0

Traditional recovery steps

After a forced startup due to a wifi connection issue, the startup stayed stuck with a grey screen, Apple logo and turning spinning indicator. Then I tried all the following solutions:

  1. Startup in Safe mode: failed
  2. Reset the NVRAM: failed
  3. Startup after checking disk and files with the disk utility of the recovery disk: failed. The disk check was successful and the permissions check revealed some inconsistencies but all have been repaired successfully. Startup on the recovery disk was successful.

Using Single User startup mode

Then I started in Single User Mode and followed some guidelines found on Apple pages and various forums.

  1. I reach a #root prompt after

    hfs: mounted Macintosh HD on device root_device
    XPCM: registered
    Root device is mounted read-only
    

    With a proposed alternative to modify the files or to continue the booting process.

  2. I applied /sbin/fsck_hfs -fy. It returned:

    ** The volume Macintosh HD seems to be OK ** and
    ***** The volume was modified *****
    
  3. I applied /sbin/mount -uw /. It finished with

    /dev/disk0s2 on / (hfs. local. journaled)
    
  4. I applied

    launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist.
    

    It returned:

    Couldn't stat <plist> No such file or directory. Nothing found to load
    

Using dscl(1)

I read somewhere that the previous error message could be ignored in some situation, but it was impossible for me to determine if it was the case here. I went into dscl(1) as the issue seemed to come from Open Directories. I stayed in the interactive mode as I'm not expert to take the risk of modifying the files and I was not sure of which files to check.

  1. The answer was the same than the previous error message indicated above: "nothing found to load"
  2. A ls command returns:

    ls: DS error: eServer error; <dscl_cmd> DS Error: -14910 (eServer error;)
    
  3. I exited the dscl interactive mode to come back at the #root prompt.

Trying to look at plist content

  1. Through the command line I changed the current directory to look at files in /System/Library/LaunchDaemons. All files are there, with dates, size and permissions.
  2. Some things surprised me. When asking a simple cd not followed by options the return is -sh: -cd: HOME not set. Maybe this is due to the Single User startup mode? The other one is that when I ask cd .. whatever could be the current directory position in the tree I get -sh: -cd: No such file or directory
  3. I then tried to open a plist to check its content with plutil -convert xml1 <file name> as I was in the LaunchDaemons directory. I first tried with another file, like com.apple.newsyslog.plist. It returns file doesn't not exists or is not readable or is not a regular file. The same answer is returned for the opendirectoryd.plist file. Files of this directory are all dated as of Sep 23, probably the date where the system was installed when I bought the MBP, the size of opendirectoryd.plist file is 698 ko and authorisations are -rw-r--r--
  4. I tried also to open one of my files in the user directories as this error message was maybe due that they were system files. But I had the same answer with a plist I built myself and I was sure to be valid as it's used by XCode in my developments.

I'm now stuck there ignoring what could be the next step. I would like to avoid re-installing the system. I feel that it's like the startup is unable to find an entry point in the directories even if the command line finds files traditionally. But it's just an assumption. If its true, is thee a way to make him find the files?

Add-on's after initial post

  1. On Feb. 8 (22:50 UTC). I got another computer to connect the MBP in target mode. I was able to open the plist with PropertyList Editor to check that the content was not corrupted. Plist files are valid, even if I don't know if their content is pertinent with the situation.

Thanks for your help. MacBook Pro (Retina, 13-inch, Late 2013), OS X Mavericks (10.9.1)

1

Your Mac has Internet Recovery, so you can boot to that and reinstall to a USB drive or SD card while leaving your internal SSD intact.

  • Should that fail, you have a good case to seek hardware repair from Apple or someone else you trust.

  • Should that work, then you can decide whether to wipe the SSD and reinstall or perhaps use the clean OS to assist in cleaning up or backing up files in preparation for reinstalling on the internal SSD.

If you repeat your fsck in single user mode, it should eventually come up clean or with a permanent error. I would use the Recovery HD to run fsck / Disk Utility since that is less likely to have corruption than your OS (which still runs in a limited mode in single user mode). It's entirely possible you have software corruption that single user mode can't fix or a failing hard drive - but given the work you've done, I'd take a positive step by installing a clean OS on a clean drive before investigating the current OS more.

  • Installation on an external HD was successful. But how to perform fsck on the former system's drive as it is no longer part of it. fsck actually checks only the external drive where new OS has just been installed. – phbardon Feb 14 '14 at 14:12
  • @phbardon So internet recovery solved this for you? – bmike Nov 11 '15 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .