The launchpad search field suddenly no longer accepts text input for me.

enter image description here

Any idea how to get this to accept text again? Searching for an app was so very useful.

7 Answers 7


Hit the tab key a few times. Worked for me.

You need to hit Tab once the launchpad screen comes up. The tab will then put focus on the search bar, and then pressing it again will remove it. Pressing it ~20times seems to cause some sort of reset. Once you visibly notice the cursor, things should be good.

Other things to try:

  • terminal > defaults write com.apple.dock ResetLaunchPad -bool true; killall Dock
  • logout / login
  • restart
  • 19
    Wow. I pressed the tab like twenty times and it actually finally started working. Weeeeird.
    – Translunar
    Nov 8, 2014 at 0:12
  • 8
    +1. Actually need to do this around 20 times to see an effect.
    – Kvass
    Dec 28, 2014 at 20:36
  • 4
    This issue is ridiculous, but the fix works!
    – Davyd Geyl
    Mar 29, 2015 at 23:02
  • 6
    +1 Incredible, the tabbing 20 times actually works!!! Thanks. Wow, how random!
    – Jérémie
    Nov 6, 2015 at 7:31
  • 5
    two years later and this is still an issue. good job with the bug fixing, apple. Feb 4, 2016 at 22:47

Hit the tab key until a cursor shows up in the search bar at the top of the launchpad view. As mentioned in some of the comments, you could have to hit it 20 times or more.


I had the same problem today. On the Apple forums, I found a tip to delete the contents of ~/Library/Application Support/Dock and to restart the Dock using killall Dock afterwards. This causes Launchpad to rebuild its database and supposedly should reactivate the search field.

I tried this and it did not work for me initially.

Meanwhile, I applied another tip, namely to repair the disk permissions with the disk tool (and then forgot about the topic).

A couple of hours later (now) - when I was looking for alternative solutions on Ask Different - I was suddenly able to search again in Launchpad.

So I expect, that either one of the tips or both in combination did the trick.

  • This did work for me, but it is another work around. If it is a bug with focus in the OS control, I hope it is addressed soon. Nov 3, 2014 at 16:55

Merely rebooting the laptop did the trick for me.


NOTE: This ALSO works when you can't rename a grouped folder on the launch pad. ie: drag two apps on the launchpad together and create a group, then open it, click the name and try to rename it. - I had to hit the tab key like 50 times.

This issue goes back many years, and isn't just OS Sierra. So whatever is around after Sierra, try this first before deleting files, messing with file permissions, or completely resetting Launchpad. This method, you don't have to logout. I have tons of stuff open all the time, and hate logging out. It's a preparation process.

So tap the tab button anywhere from 20 to 50 times. It's worth a shot before doing anything else :)


In the Launchpad, press Cmd + Shift + esc. The pad will fade and zoom, and when you hit it again it works so you can type again.


Tab 20 times or so worked for me.

  • Please explain more about how tabbing 20 times will allow this to work?
    – fsb
    Apr 3, 2017 at 22:48
  • 1
    Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info on how tabbing 20 or so times will address this issue. Also, you may want to read How to Answer for tips on providing answers here.
    – Monomeeth
    Apr 3, 2017 at 23:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .