4

Since I upgraded to Mavericks, whenever I plug in my iPod, Spotlight tries to index my iPod. I don't want this to happen, since it puts a lot of stress on the iPod's drive (iPod 4th Generation, 40GB), and I don't really need it to be indexed. This has not happened with previous versions of OS X.

I've tried excluding the iPod from the Spotlight settings, but it still is preparing to index the iPod when I open Spotlight.

Is there a way to exclude the iPod from the Spotlight indexing?

enter image description here

Update

It looks like there was an error when I first tried to add my iPod to the list of excluded items in Spotlight's Privacy settings. When I opened the settings again, it wasn't listed there anymore. I added it again, and this time it worked - the indexing stopped.

For some reason it ignored it on my first try.

  • 1
    If you don't need the iPod to be in disk mode (set in iTunes > iPod > General Settings) then disabling it will prevent it from happening again by a different mac. – Andrew U. Feb 6 '14 at 14:45
3

According to Apple in Mountain Lion You can disable it in privacy settings. This same setting is visible in Mavericks, so you should be able to remove your iPod being indexed this way.

As to test this setting for you, I've added a 2 partitioned USB HDD on my MBP, and removed the index. It stopped to index immediately.

  • The OP said he already tied excluding the iPod from the Spotlight settings. – Thecafremo Feb 6 '14 at 9:07
  • @Thecafremo unchecking it in Privacy settings removes it. There's no hidden stuff, it's there not somewhere else. – Rob Feb 6 '14 at 9:29
  • I don't understand what you mean. I meant that the OP already said that he had already disabled it in the privacy settings, which is, as the OP says, in the Spotlight settings. – Thecafremo Feb 6 '14 at 9:52
  • Please see my updated question - I tried adding it again in the Privacy settings, and this time it worked. In the first try, it somehow added it in there, but still tried to index it. When I opened the privacy settings again, the list of exclusions was empty. Adding it again did the trick. Don't know what went wrong the first time ... – nwinkler Feb 6 '14 at 12:40
-1

I would check into privacy settings.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .