3

I am using a Gigabit Ethernet adapter (Apple) to connect to my network. While downloading larger files the MacBook Pro blanks the screen and disconnects the network even though it is active doing the download.

Being new to Mac, I don't know where to look other than in the System Preferences under Energy Saver and Network. Is there any other place to check in order to stop this behavior?

3 Answers 3

2

What OS is it? 10.9 shouldn't have this problem if you update. Just make sure the network access is checked in energy saver.

Alternatively: 'Note: Portable computers have no network connectivity when in sleep mode, but can wake if the Energy Saver option "Wake for network access" is enabled. If you wish to use file sharing or don't want to interrupt your Internet connection, you should not manually put the computer to sleep, and you should drag the "Computer sleep" slider to Never.'

http://support.apple.com/kb/HT2412

1

You're already in the right place. In Energy Saver press, set the sleep time to Never.

Perhaps a more convenient option is to use the free app Wimoweh. You can set it to never sleep only while certain apps are running. http://www.serialangels.co.uk/index.php/wimoweh/

2
  • There is also Caffeine, although it doesn't allow you to specify which apps to prevent sleep. It's more of an allow sleep, never sleep button in the menu bar: lightheadsw.com/caffeine
    – pknz
    Commented Jun 9, 2014 at 2:49
  • Wimoweh does not seem to be a free app. It's listed in the Apple app store at £0.99.
    – ccpizza
    Commented Jul 16, 2018 at 9:53
0

Setting Disable idle sleep in InsomniaX will prevent network from dropping.

It is a free and open-source app with source code available on github.

It is abandonware and the author has a security vulnerability note on his site, yet it works fine on High Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .