8

I've upgraded to Mavericks from Mountain Lion. I've used the keyboard shortcut "Control" + "number" to switch between Spaces. The upgrade broke this. I've checked System Preferences and all the settings are the same as before. Is there a fix to restore this feature? Thanks

  • The exact same bug is present within Yosemite. • I confirm that at the same time [Ctrl]+[→] and [Ctrl]+[←] are working, that the problem is local to one user session, and not associated with any file corruption. – dan Apr 25 '16 at 17:30
7

I actually figured out how to fix this on the fly.

I believe this state occurs when you inadvertently make a swipe gesture while a ctrl-key is held down. I can't be sure of that, but the fix is to do exactly that: hold down the ctrl-key, and then do the desktop-switching swipe gesture (for me it is 3-finger swipe left or right).

I don't know how to prevent it from happening, but it's so quick to fix that it has become a non-issue for me.

  • 1
    This totally and inexplicably worked. – Daniel Beardsley Feb 16 '15 at 23:47
  • I +1'd, but just to confirm that this was the solution, even though I'd gone into Preferences, Keyboard, and checked that I had the proper keyboard-shortcuts enabled. Ctrl-→ and Ctrl-← still worked, it was just the Ctrl-number shortcuts that didn't. – Sam Kington Mar 17 '15 at 2:33
  • Not sure how you found this, but totally works for me. I have the settings and it just stopped working randomly. Thanks for finding this @Avram ! – Boushley Dec 31 '15 at 21:42
  • Has no effect for me. – Tvaroh Feb 13 '16 at 11:26
  • Great! You found a bug here in the dealing of [ctrl]+[1]…. I didn't find how to reproduce it yet. But your receipe fixes the state machine without rebooting or any other painfull religious procedure. – dan Apr 25 '16 at 17:22
5

System Preferences > Keyboard, as seen here:

System Pref

Only existing desktops will be shown here, so first add the desktops, then come here to check the boxes.

  • I understand. I deleted all the Spaces then created a new one. Same result. – john1975 Feb 5 '14 at 17:50
  • This solution worked for me. Please note that it can only switch between desktops, not fullscreen application. – pietrodn Feb 5 '14 at 18:18
  • I understand that. I had this problem with Mountain Lion when I created a second standard account on this Mac mini but since my main account still performed normally I tolerated it. Now the problem has affected my main account. – john1975 Feb 5 '14 at 19:44
  • Sounds like something isn't sticking with your SymbolicHotkey preference file, cause even after closing and then reopening your extra spaces, the shortcut being enabled should still persist. On both my Mac Mini and my MacBook Air, it does so for me with no problems, including with a logout-login in-between closing and reopening the spaces. Follow the Answer by @Matt-Manuel further down this page to recreate your Hotkey preference file and try it again, and let us know how it goes? – FreelancerJ Feb 8 '14 at 12:52
  • I've followed Matt's procedure several times. The situation still persists. – john1975 Feb 12 '14 at 13:59
2

Try this. Move the keyboard shortcuts plist file to your desktop. It'll be recreated when you log out / log back in again, with defaults set and should reenable your shortcuts.

  1. Open Terminal. (LMK if you need more detail here.)

  2. Paste this into Terminal and press Enter / Return:

mv ~/Library/Preferences/com.apple.symbolichotkeys.plist ~/Desktop/com.apple.symbolichotkeys.plist

  1. Log out and log back in again.

Your shortcut keys should be working again. If they are you can safely trash / delete the plist file on your desktop. We just moved it there as a backup in case it didn't fix the problem.

  • I completed this, deleted all Spaces and added new ones - no joy. Thanks anyway. I'll add this detail in addition to the other ones I've put in the comments of the other answers offered. From the beginning the "control"+"number" keyboard shortcut only worked with with Spaces 1-4. It wouldn't switch to Space 5 or above. Thanks for the advise. – john1975 Feb 9 '14 at 16:23
0

When new spaces are created, the little check boxes along side the shortcut in the mission control shortcut's are not ticked automatically. Therefore new Spaces are not enabled.

Make sure they are ticked.

enter image description here

Also you could try and change the shortcut to something else. Try those to see if they work.

If they do. Switch them back and try again. If not still switch them back and see.

  • Oh yes I checked, unchecked, added new spaces, rechecked etc. etc. Thanks for the reminder. – john1975 Feb 12 '14 at 13:57
0

I have had the same problem and think I just solved it for me.
Go through each one and put the shortcuts in manually. For example, 'Control' + Keypad 1 now goes to Desktop 1. The default settings it just used to beep.

0

This is going to drop right to the bottom of the answers list to start with, of course… however...

If you have an extended keyboard with a 10-key/num-pad to the right of your main keyboard, then in System Prefs > Keyboard >Shortcuts

Ctrl ⌃ + "number key above the qwerty"
is not the same as
Ctrl ⌃ + keypad number.

This is quite important, as the newly-created shortcut in System prefs when you create a new Space [even though disabled by default] is

Ctrl ⌃ + "number key above the qwerty"

…so if you need Ctrl ⌃ + numpad instead, you must replace the key combo, even though they look identical.

-1

I had a somewhat similar problem with 10.8 where bluetooth keyboard would stop responding. If I turned off bluetooth, then the built-in trackpad and keyboard would freeze.

I tried all kinds of things, terminal commands, xcode bluetooth explorer, etc.

Believe it or not, The best solution turned out to be -- Logging out and logging back in.

It was suggested from a forum and it does sound like bollocks. But give it a run.

People love Alfred and I've been using Quicksilver to emulate Spotlight. Perhaps it would be worth setting up either of these as hotkeys for "Control" + "number" to switch between Spaces?

  • Thanks but my keyboard is wired. The problem has persisted through log outs, restarts and power off cycles. The problem is not intermittent but persistent. In Mountain Lion it had been present in another account on this computer but not on the main account. Thanks for the insights. – john1975 Feb 5 '14 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .