1

I have a recurring problem:

My MacBook Pro recognizes and connects to my building's wifi network (the provider happens to be Natural Wireless).

But it doesn't redirect to their boring terms page that I have to click that "I agree" to in order to access the internet.

I have numerous other devices connected, so they're not down. Also, my computer's wifi works fine. (I'm connecting with my phone to the hotspot and my computer is connected using the phone's wifi, so I'm sure both work.)

I'm pretty sure the computer (or hotspot) just thinks they already know each other, so it's not redirecting to the agreement. I think this because the remedy on mobile devices is to "forget" the network, then reconnect.

I've tried that on the computer successfully in the past (removing the network in the "advanced" section of network settings, then re-connecting), but it no longer works.

I also tried hitting both 127.0.0.1 and 192.168.1.1 - neither helped.

1

Try manually accessing a page using http, not https, and try it with multiple browsers.

The captive portal test just tries to pull a file from one of Apple's servers. If it doesn't match what it's expecting, it knows it's not on the open internet and shows the login page.

Some providers let the test through to avoid this behaviour. If you open up a web browser and try to access a page via http (not https) you should see the login page.

  • I'd actually tried this and it didn't work in Safari. But after trying in chrome, and deleting the "s" in https, I can get in consistently. – Jaydles Jun 10 '14 at 21:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .