I would like to have some additional calendars that are not synced through iCloud on one of my computers. I have been using this calendar to run small programs at certain times. These programs are however only (a) available on this one machine and (b) would not even be allowed on e.g. an iPad.

As I am currently forced to sync the calendar to all my devices however my iPad is turning the custom alerts into normal standard alerts. Breaking the entire calendar.

Is there a way around this? Thanks!

  • You should have the ability to create a local calendar, not in iCloud. I'm not in front of a Mac right now so I cannot tell exactly. Just create one, and drag it to "My Mac" – Rob Feb 4 '14 at 7:18
  • 2
    The "On My Mac" disappears as soon as I turn calendar on in iCloud.So there is no way I can see to move any of them to "On My Mac". – MatoBehr Feb 4 '14 at 8:25
  • See other (Yosemite) answers here: apple.stackexchange.com/questions/161997/… – Steve Moser Sep 3 '15 at 17:31

A co-worker figured this one out for us:

In Calendar, go to Calendar: Accounts, select your accounts you are using in Calendar and uncheck "calendar" from the section where it says "Use With".

Once there are no internet accounts available, Calendar will allow you to set up an "On My Mac" local calendar.

Once that's set up, re-check the "Use With: Calendars" checkbox and all should be well.

Caveat: for us, we were able to check and uncheck this setting without having to set anything up again. I won't guarantee this will be the case for you, so be sure you know how to set up your accounts again and as always, have backups.

  • 1
    Once I did this and re-checked calendar under iCloud, it basically moved my local calendar INTO iCloud. – jlarson Jun 7 '16 at 18:17

I've managed to do this (by accident). I created an exchange account that does not work but is still on the Mac as an account. I now can create local calendars under this in the calendar app and use them to launch applications etc. Seems to work well so far and does not sync to iCloud or any other devices.

  • Cool, I will try this out as soon as I have time. – MatoBehr May 29 '14 at 15:01

There's another easy workaround to this.

  1. Uncheck "Calendar" inside Systems Preferences/iCloud. At this point, you won't see any of your icloud calendars.
  2. Now create a new calendar, and that will be put under "On My Mac". You can call it anything or just untitled. This creates the "On My Mac" folder for you.
  3. Re-check "Calendar" inside Systems Preferences/iCloud. Now you can drag any or all of your iCloud calendars onto your local folder.
  • Thanks Jen - not sure why it needs a "workaround" and Apple does not let us choose: local or iCloud when adding an calendar?!? – Xl S Nov 5 '17 at 0:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .