1

When opening files from a Finder window, I want them to open in the active Space, regardless of the application already being open on another Space. Instead, they open in whatever Space already happens to have an open window of the application. I've noticed this particularly with Microsoft Office programs, as I tried to reproduce it with Preview and Terminal windows but they seemed to behave properly, so I think that this problem lies within the MS Office suite.

I imagine that this is related to this question, but this occurs with windows that aren't minimized. Similarly, I've already unchecked three of the options in mission control;

  • Automatically rearrange Spaces based on most recent use
  • When switching to an application, switch to a Space with open windows for the application
  • Group windows by application

If there are any known methods of disabling this behavior it would be much appreciated.

1

Apple's website:

If you work in multiple spaces, you can assign apps to particular spaces.

Press and hold an app’s icon in the Dock. You may have to first open the app from Launchpad to see its icon in the Dock. From the shortcut menu that appears over the icon, choose one of these: To have the app open only in the current space, choose Options > This Desktop. From now on, the app will open in the current space; if you are working in a different space, the app’s space scrolls into view.

This setting doesn’t apply to full-screen windows, which always appear in their own separate spaces.

To have the app open in every space, choose Options > All Desktops. From now on, when the app is open it will appear in every space.

To have the app open in the space you are currently using, choose Options > None.

In Mission Control preferences, you can specify that when you switch to an app, your desktop should scroll to a space with open windows for that app.

THis should allow you to choose Office programs to open in that desktop

  • Currently running 10.9.2, didn't work. – agweber May 5 '14 at 18:59
  • @agweber edited it, please try this method – ᔕᖺᘎᕊ May 5 '14 at 19:02
  • That method ties the program to one desktop. I often am working on several tasks that I personally assign to a specific Space. I would like to have documents open in different Spaces related to the task I'm working on. – agweber May 5 '14 at 19:11
  • @agweber sorry, didn't realise that. – ᔕᖺᘎᕊ May 5 '14 at 19:11
-1

I have the same issue as agweber.

I like to organise my spaces/desktops according to my work projects, NOT by apps. I therefore may have 3 or 4 desktops, each using several of the same apps.

The dock option for all my apps is "None", rather than "All Desktops" or "This Desktop".

When I open a file on any desktop using a Mac app it will open right there even if the app is already being used on another desktop.

However, if for example an MS Office Word file is open on Desktop 1 and I try opening another Word file when on Desktop 3, it automatically switches to Desktop 1 and opens there, requiring me to drag it back to Desktop 3. None of the 3 dock options will remedy this.

This only seems to be an issue with the MS Office suite, and I've noticed it's the same whatever the OS X version I've used since 10.6 (I'm currently on 10.11).

It seems MS Office for Mac is not designed to function with Mac desktops in the way native Mac apps do.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .