0

I have recently bought an SSD and a HDD caddy to do a SSD+HDD setup. After installing, I can't format or reliably use my HDD while it's in the optical bay.

I installed the SSD in the place of the original HDD and it worked without any problems at all. Then I installed the HDD in the optical bay with the caddy and it seemed to work as well. This HDD was not changed since it was removed from the main drive bay and it still had OS X(and all my other files) on it.

One thing I realised at this point was I was unable to boot into my HDD which was not changed at all. Still I was able to access my files and copy over the needed ones to my SSD. I didn't try to do more (write, etc) so I don't know if more functionality was present.

Then I tried formatting the HDD and it hanged for a long time until I had to power off the computer and start over. I knew this would corrupt the partition scheme(obviously) but I figured that this would be OK and I can just simply reformat later.

After discovering that formatting doesn't work (with the error message: "disk erase failed with the error wiping volume data to prevent future accidental probing failed") I tried the command line (diskutil eraseDisk JHFS+ HDD1 disk1) but this also throws the error (Error: -69825: Wiping volume data to prevent future accidental probing failed).

At this point I took the drive out of the bay, put it in a USB HDD dock, connect it to Windows and format it as FAT32.

This worked and when I put the drive back in my Mac it appears to be working until I tried copying a file to the disk. At this point it gave an error(something along the lines of: Can't read and write from the SOURCE_FILE) And when I tried to reformat it in my Mac it again corrupted the disk.

At this point I am inclined to think that this is an issue caused by the caddy. To test this I will try putting the SSD in the optical bay and try booting off that.

In short: My problem is that I can't format or reliably use my HDD while it's in the optical bay. Any ideas?

  • Welcome to Apple.StackExchange. I've tried to understand your question, but I'm missing the "one-liner question". What is the actual problem summarized? Or is it just you cannot format one HDD via Mac? – Rob Feb 3 '14 at 10:58
  • I will produce a summary ASAP. – Code Bunny Feb 3 '14 at 11:05
0

So the problem was with the cable. Apparently one of the small pins on the cable that connected the optical drive to the motherboard, got broken.

If it was a total failure of the drive this may have been more obvious, alas, it was not. It merely caused the drive to work in an unstable manner.

As soon as I replaced the flex-cable with a salvaged one, the problem disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .