2

Whenever I send someone a text, I'm told that it shows that "myname@icloud.com" is sending the text and not my phone number. And when someone responds to "myname@icloud.com", I receive the message on my computer and Wi-Fi only iPad, but not my iPhone. Is there any way to only send and receive messages from a phone number?

5

In your Settings go to Messages> Send & Receive and you should be able to set your preferences from there. Go to the "Start New Conversations From:" section and set your phone number to be the default.

If your phone number does not appear, turn FaceTime off and on. Phone number should show up

|improve this answer|||||
  • 1
    Thanks! For some reason my phone number didn't appear in the "Start New Conversations From:" table. I tinkered with it and by chance tried turning "iMessage" on and off and my number appeared there. – pasawaya Feb 3 '14 at 4:23
  • Awesome! Glad it worked for ya! – daviesgeek Feb 3 '14 at 8:05
1

Go to

  • Settings
  • Messages
  • Send & Receive
  • Uncheck the email address(es) just leaving your phone number checked.

You should be good from there.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .