My Mac hung overnight and was in a bad enough place that I had to power cycle it this morning. When it came back up, I logged in and found that a number of the apps in my dock had a slash through their icons. When I tried to launch them, a dialog came up informing me that they could not be run on my Mac.

I logged in as a different user, and these same apps worked fine. I also tried deleting and reinstalling some of them, and those apps were fine thereafter. However, some of the affected apps are stock applications that come with the OS (e.g. Terminal.app), so that's not a great solution.

Launching the apps from the command line works fine. I also found that zipping up the app package, deleting the original, and unzipping the copy seemed to get things working again.

My suspicion is that the Finder or another component has cached information about these apps, and that the cache has been corrupted. This would explain why things are fine for other users on the system. However, I don't know where that information might be stored. I've tried deleting the Finder preferences and the entire contents of ~/Library/Application Support/Caches to no avail.

Is there an easy way to get my account back to a good state, or am I stuck with manually fixing each app one at a time?

Update: Further testing has revealed that zipping and unzipping affected applications is not 100% reliable. Sometimes it works and sometimes it doesn't. Furthermore, sometimes merely moving/renaming an application is sufficient to get it back to normal, but sometimes that has no effect, either. This only makes me more interested in finding a real solution.

  • I recently had this happen to some apps on a DVD. Rebooting a couple of times cleared it up; but since it occurred on a read-only media, you can rule out anything having to do with the app specifically, I think.
    – Kent
    Commented Feb 2, 2014 at 3:23

2 Answers 2


If it is a cache problem then I would suggest running AppleJack to clear caches and fix permissions.

It's a wonder of a tool. It would be my first step.


I wasn't able to find a satisfactory, automated solution. I did, however, find something that worked for individual apps.

Since each of the affected applications were Apple-provided apps, trying to drag them to the trash produced a message indicating that they were required by the system, and could not be removed. Somehow, this action reversed whatever was causing the application to be flagged as un-usable, and things started working again. So I simply tried to delete each application one at a time; I don't know if dragging them as a group would have worked.

I still don't know exactly what caused this, other than the fact that the system was in a really strange place overnight. I'm going to run a backup, cross my fingers and hope it doesn't happen again.

  • The time to backup is when you don't need to, not after you wish you had one. :)
    – Harv
    Commented Feb 4, 2014 at 22:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .