1

I have a 13" MacBook Pro early 2011 model. It will not boot from any Linux USB boot disks I have created. I know these disks are working on later models as I have tried with 2012 Retina 15" booting and working fine.

I have tried using rEFInd and various Linux distros but none will be detected on the 2011 model. I found this post:

Can I boot Linux (any distro?) from USB on a MacBook Air that has no hard drive?

However I am not sure where I can get the EFI drivers as the ones on the apple site are .pkg format and doesnt seem to be anything I can extract to copy to /efi/boot?

  • Would booting from DVD be an option? – nohillside Feb 1 '14 at 16:02
  • Unfortunately not as it needs to be used on retina Macs. Idea solution is to get it working on USB stick or removable hard drive but I am not what else to try to get the disk booting on older Macs – MBP2013 Feb 1 '14 at 16:11
  • Did you try to follow this guide? Bootable USB sticks created this way work well on my MBP "classic" mid 2012. ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx – pietrodn Feb 1 '14 at 21:03
  • Yes this is the guide i have been using for creating all my boot disks – MBP2013 Feb 2 '14 at 22:39
2

Try to use dd:

dd bs=4M if=path_to_iso of=path_to_usb && sync

Replace path_to_iso and path_to_usb with appropriate paths.

  • thanks for the suggestion but unfortunately tried that and it wouldnt let me boot on either machine.. Anything else you could possibly thing of I could try please? – MBP2013 Feb 1 '14 at 19:11
  • tech-devnet.blogspot.de/2012/05/running-ubuntu-1204-on-mac.html There you can find some helpful stuff. – enedil Feb 1 '14 at 20:44
  • Found a lot of useful info on that site including the wiki which shows which mac versions are compatible with which ubuntu versions. Due to it being a universal installer though i don't think it will work that way as each device needs configured differently. – MBP2013 Feb 4 '14 at 10:20
0

What I read around the internet is that some recent MacBooks don't support USB boot at all, because some EFI stuff are unloaded then reloaded. When EFI unloads USB stuff your disk get's disconnected. The code to load it again is inside the disk that's now disconnected so it cannot be executed. At least that's why you can not boot a windows usb disk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .