4

I would to ask a question closely related to already existing posts (How to install command line tools without error that is not currently available on Software Update server? and https://stackoverflow.com/questions/19691701/failed-to-install-command-line-tools-on-osx-mavericks) but with the help of which I still could not fully solve my problem.

I have a MacBook Pro running Mac OSX 10.9. When I run xcode-select --install from the terminal, the command fails with an error message Can't install software because it is not currently available from the Software Update Server (see second linked post for screenshot).

It was suggested by many to simply download the command line tools package from the developer website, which I have done (already had an account). My question, is the second procedure strictly equivalent to running xcode-select --install? I have suspicions that the paths to the different libraries and headers are not defined in the same way when downloading and executing the dmg.

I am running particle physics software called root and compiling with the available C++ interpreter fails with "Undefined symbols for architecture x86_64" error, probably due to the use of standard libc++ instead of libstdc++. Strangely enough this problem does not appear on another computer (running same OSX 10.9) where I was able to run the xcode-select --install command.

Is there any way to solve this error message when running xcode-select --install? People have suggested this could be due to the fact that command line tools are already installed but I have both tried deleting command line tools by hand (sudo rm -rf /Library/Developer/CommandLineTools) and even a clean install of Mavericks but no luck.

  • 1
    That error "Undefined symbols for architecture x86_64" is not due to libc++ It is because you have some libraries in 32 bit only and the main is in 64 bit (or in both) - this is one reason I use package managers like macports/fink/homebrew as the porters will tell you if it can't be fixed . root is a very complex build – user151019 Dec 15 '14 at 16:25
1

Are you sure they are installing the same version?

At the command line on both machines run cc -v - the latest version seems to be Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn).

  • Hi, yes I have already checked versions on both machines and they are the same, namely the one you mention in your post. This is why I suspect some different flag setting somewhere and would like to try the xcode-select --install method to make sure. Thanks for your help. – ppsao85 Feb 2 '14 at 8:23
-2

Also, try running

export

to see what environment variables you have set; it's likely that the development tools are prefixed somewhere you don't have a path, so the shell can't find them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .