10

My truecrypt files were mounting fine until today when I tried to mount it and I got the error: the OSXFUSE file system is not available (255). The weird thing is I honestly don't know what I could have done on my computer since yesterday when there were no problems that would have caused this. I tried deleting macfuse and osxfuse and redownloading both but it still doesn't work. The weird thing is when I remove OSXfuse it says it is not available (-1) and when I have it says the same thing but with (255). Is there anything I can do to get my files back? I am on mavericks if that matters.

Thanks!

  • I think I had the same issue, did you upgrade TrueCrypt? If so you will need to update your encrypted volume. I had almost the same error when I upgraded TrueCrypt then tried to mount an encrypted volume several weeks later - no go. I first tried to install the old version of TrueCrypt checked that the volume was still ok. If that is not the issue then you may have to try restoring the volume, I don't think it is anything to do with osxfuse. Also try reinstalling TrueCrypt. What verson of TC are you running? – Deesbek Jan 31 '14 at 2:07
  • I don't think I've updated TrueCrypt since the volume was mounting fine. How would I restore the volume? I am using TrueCrypt 7.1.1 – user3255503 Jan 31 '14 at 2:15
  • Do you use TimeMachine? I always backup my volume files, in fact I have three copies. One backup at the office, and one off-site, which I update once a month. If there is something critical going in there more often. – Deesbek Jan 31 '14 at 2:21
  • No I don't have any unencrypted backups. I was hoping there was something I could do to fix this because it was working 2 days ago and now its not its so strange. The only thing I can think of that has changed on my computer since two days ago is I installed parallels. But that is it and I don't see why that would have an effect. – user3255503 Jan 31 '14 at 2:23
  • Installing parallels should not effect it. I use VMware Fusion, and have never had any compatibility issues with TC. What about the encrypted volume - you should back up the ENCRYPTED volume, that way the backup is secure as well. You should always keep a backup, I have had a TrueCrypt volume get corrupted, moving from Android to OS X, but luckily I had the encrypted volume backed up. Having said that I would not give up hope. – Deesbek Jan 31 '14 at 2:25
13

I had a similar problem today. I installed osxfuse and ntfs-3g via Homebrew, but I didn't install the kernel extension. I got a similar error message trying to mount an NTFS drive in RW mode. After installing the osxfuse kernel extension (instructions are available via brew info osxfuse), the error went away. Strangely, it didn't happen the first time I mounted an NTFS drive using ntfs-3g.

I hope this helps.

  • I just installed Homebrew by typing: ruby -e "$(curl -fsSL raw.github.com/Homebrew/homebrew/go/install)" into terminal and I still can't mount the truecrypt volume. I also can't make any new truecrypt volume because of the osxcuse filesystem error. I don't get what has happened because everything was working fine a couple days ago. With that generic install of homebrew does it also install the osxfuse kernel extension? If not how do I do that? thanks – user3255503 Jan 31 '14 at 23:53
  • @user3255503 sorry, i'm just seeing this. you probably need to install osxfuse as well, with the command brew install osxfuse. – darkphoenix Feb 21 '14 at 14:17
  • 2
    I was only able to install osxfuse using brew cask install osxfuse, I think osxfuse was migrated to cask – Sebastian May 19 '17 at 13:50

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .