1

I'm not 100% sure if this is just my misinterpretation of the mount output, or if this is actually an issue. I'm mounting an nfs share with the following command:

mount -t nfs -o nolocks,noowners 10.0.0.1:/vol/shared ~/shared

But when I look at the output of mount I see the following:

10.0.0.1:/vol/shared on /Users/ryan/shared (nfs, nodev, nosuid, noowners, mounted by ryan)

Why isn't nolocks listed in the options? The reason I need this option enabled is that the server I'm connecting to doesn't have locking enabled, and when I try and use the share I experience extremely slow performance as a result (at least this is the most likely reason). I'm fairly sure that it isn't mounting the share with locking disabled, because I'm still experiencing the same issue.

  • What is the output of mount_nfs? – user10355 Jan 30 '14 at 22:26
  • usage: mount_nfs [-o options] server:/path directory – Ryan Lynch Jan 30 '14 at 22:49
  • No, I meant if you mount using mount_nfs rather than mount. – user10355 Jan 31 '14 at 1:50
  • 1
    Ah. The result is the same. – Ryan Lynch Jan 31 '14 at 15:11
-2
nfsstat -m 

It shows the options from mount_nfs

  • 1
    I don't see how this answers the OP's question. Can you expand on the details, please? – Allan Dec 5 '18 at 13:58
  • To see if the option nolocks is applied you have to look at the output of the command 'nfsstat -m' not 'mount' – Alejandro Teijeiro Dec 5 '18 at 19:08
  • The OP didn't ask to see what the options were, the question was why was the option being ignored? – Allan Dec 5 '18 at 19:10
  • You have to start by looking in the right place first to see if the option is being ignored, from the output of mount you can't tell – Alejandro Teijeiro Dec 5 '18 at 19:12
  • Here is an output example # mount example.com:/export/home on /home (nfs, nodev, nosuid, automounted, nobrowse) # nfsstat -m NFS parameters: vers=3,tcp,port=2049,nomntudp,hard,nointr,noresvport,negnamecache,callumnt,nolocks,quota,rsize=32768,wsize=32768,readahead=16,dsize=4096,nordirplus,nodumbtimr,timeo=10,maxgroups=16,acregmin=5,acregmax=60,acdirmin=5,acdirmax=60,nomutejukebox,nonfc,sec=sys – Alejandro Teijeiro Dec 5 '18 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .