12

Using a Mac with Mavericks, I have keyboard setup to Hebrew. Then, when I click in the password field, it switches it back to English and Hebrew is disabled.

I saw that another question says to remove the keyboards, but I need to keep both Hebrew and US input methods active. I don't use quicksilver and wonder if something else might cause this problem on Mavericks?

  • Is this independent of your browser? I have noticed that Mavericks auto changes the keyboard layout to your system locale when entering passwords in the user login window. Maybe the same happens in Safari now... – codingFriend1 Feb 11 '14 at 15:07
  • I observe the same behaviour when using chrome. However, it did not happen in safari nor firefox (same settings and same website). – dh82 Apr 20 '14 at 11:51
  • I found a fix presented in this related question. – dh82 Apr 20 '14 at 12:03
1

After doing a little bit of testing, I think it's because of this option is enabled in System Preferences > Keyboard > Input Sources:

Automatically switch to a document's input source

It's checked by default and since cbs.com is in English, OS X will automatically change the input source to English (If you don't have English, or whatever language the page is in, enabled, it seems it'll just select your default input source — i.e. the one at the top of the list in Input Sources).

I tested with Hebrew and Danish enabled and when focusing a textfield OS X changed my keyboard layout to Danish with auto-switch enabled and didn't with it disabled.

At least in my case, the swithcing wasn't limited to password fields specifically (which makes sense). The behaviour is the same in both Chrome and Safari.

  • Sadly this does not fix my problem (macOS 10.14 Mojave). Last version worked just fine and also other programms work with other layouts. – gr4nt3d Oct 6 '18 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .