3

On a MacBook Pro with OS X 10.9.1 (13B42) with both the trackpad and a Bluetooth "magic mouse" I observe an excessive amount of (especially) horizontal scrolling.

A trivial touch to the mouse (or touching the trackpad with two fingers) may result in dozens of (especially horizontal) scroll events. This is especially pronounced in Excel, Firefox, and Emacs (which notice horizontal scrolls) but not in Terminal and Outlook (which mostly ignore them).

Mouse tracking in system settings is set to the 3rd notch (out of 10).

It is possible to disable or reduce horizontal scroll events?

  • This is still a valid question in Yosemite and from what I have read online MagicPrefs causes more problems than it fixes. I agree with @sds that the problem is much worse in Excel and that Apple apps seems to behave OK. – ukayer Jul 6 '15 at 23:12
  • 1
    I've added to my answer a way to completely disable mouse and trackpad scrolling. – empedocle Jul 9 '15 at 16:48
2

Yes, you can disable horizontal scroll events. I know this because unwanted horizontal scrolling with the Magic Mouse used to drive me insane, especially with Adobe products.

MagicPrefs, a "free application […] to improve the functionality and configuration options of the Apple Magic Mouse", indeed let me disable horizontal scrolling. It's somewhere in the "Magic Mouse" settings tab. Hope this helps.

  • It certainly does help - thanks! I've just got a MacBook Pro and Magic Mouse, and the horizontal scrolling esp. in Sublime Text was driving me crazy. There is supposedly a Terminal command that fixes the problem but it doesn't work for me on Yosemite. – Frank H. Jul 31 '15 at 8:51
0

The other setting that affects scrolling is "Scrolling speed" under Accessibility > Mouse & Trackpad. From the documentation:

Adjust the speed at which you scroll through documents and windows using the mouse.

enter image description here

Change it for both Trackpad Options… and Mouse Options…

Unchecking Scrolling in the same Accessibility preference will disable scrolling completely.

0

My Specs - OS 10.8 MacBookPro - Adobe products - excessive and unwanted scrolling within the application. I can verify that the terminal route should be avoided (unless you know what you are doing) as it affects the operating system at code level. The second fix above (accessibility preferences) works but turns OFF the magic mouse scrolling universally - its useful for web browsing and you have paid triple for an advanced mouse... to turn it off?

The simple solution is to have a wired, traditional Mac Mouse (none Magic) attached to your keyboard - swap to this for Adobe work... takes seconds to alternate and you don't have to turn anything OFF. You will find one on ebay as Apple don't ship them anymore. Or you can put a dongled Windows mouse on the Mac (USB flash connector - wireless mouse) - in both cases the Mac will accept the none standard mouse using a base driver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .