I have installed a fresh version of mavericks on a MacBook Pro 13". After the computer wakes up from sleep, I have no sound - neither in earphones nor in speaker.

The problems has been reported by many users in the Apple support community.

Is there any solution besides rebooting?

  • It looks like a number of different fixes are suggested in that thread, have you tried any of those? – Robin Jan 29 '14 at 16:06
  • 2
    Reboot works for me, but I am looking for a canonical, authoritative answer rather than a 6-page forum discussion. That's the whole point of stack exchange sites! – Adam Matan Jan 29 '14 at 16:07
up vote 5 down vote accepted

I had to reboot, but to summarize the thread's problem and apparent solution, which worked for me (but only for a week): The problem occurs if your macbook goes to sleep with earphones plugged in for a sufficiently long time (more than 1h) when it wakes up audio won't work. ALSO some people notice overlay for changing volumes doesn't respond (it actually did for me), and plugging in or removing headphones doesn't trigger any change in the sound settings as to which device (speakers or headphones) is displayed for output.

You should try to trash the com.apple.audio.DeviceSettings.plist and com.apple.audio.SystemSettings.plist in /Library/Preferences/Audio and reboot with a reset of pram (hold command-option-p-r before you power on, and until you hear a second boot "bong" sound). This stopped it from recurring for me when the laptop went to sleep with headphones plugged in - for a week; later it happened again when sleeping while the quicktime player was playing an mp4 video with headphones plugged in.

As an aside I have another sleep-waking issue where the network won't reconnect properly (wifi, to an 802.11N access point) but instead will show it's connected to the right point, and no traffic will go out (E.G. can't ping 8.8.8.8, nor 192.168.0.1) this was also supposed to go away if one clears pram, but it did not. The work around there is to turn off wifi, and turn it back on.

There's even a rumor that if you always use the power adapter that came with your macbook pro retina the pram fix will stick, while switching to an adapter with the old style magsafe plug causes it to recur. It gets a little too tin-foil-hat for me.

  • 1
    2009 MBP with a drive swapped in from a late 2008. Trashing the plists and resetting the pram was the only solution in this thread that worked for me. – Michael Jul 19 '14 at 3:26
  • This happens to me without headphones plugged in - it started about a month before Sierra was released (possibly coinciding with a late El Capitan update) - and has now continued in Sierra. If I didn't know better I'd say the code has regressed and an old bug is back! – niico Oct 3 '16 at 17:51
  • @niico thanks for the comment because guess what, my MacBook Pro Retina 15 2015 just did the same thing to me on El Capitan as of the security update prior to the Sierra release. Yes. It is back. I've had a bug report open with apple for a week and all I have from them so far is to run sysdiagnose or press shift-control-opt-command-period and attach /var/tmp/sysdiagnose* to the ticket, which I did. I haven't updated to Sierra, just in order to follow up on this bug with them. – dlamblin Oct 7 '16 at 11:11

I could fix the problem by reloading the kernel extension for audio with these command:

sudo kextunload /System/Library/Extensions/AppleHDA.kext
sudo kextload /System/Library/Extensions/AppleHDA.kext
  • This worked for me on a hackintosh. – msfeldstein Apr 24 '14 at 1:46
  • This solved my problem on MBP. – Shanison May 4 '14 at 8:30
  • 2
    WORKS AS ADVERTISED <3 The last think I want to do is close the 20 firefox tabs I have open, save 5-10 terminal windows, and restart whatever virtual machines I have running locally. This lifehack insta-fixed it. Thanks! – amateur barista Jun 4 '14 at 21:22
  • This doesn't prevent it though does it? – dlamblin Jun 19 '14 at 4:00
  • 1
    This doesn't work for me in El Capitan. – Makoto Nov 24 '15 at 5:12

The first suggested fix worked for me . I wrote a quick script that runs both of them, you can get it by running either

cat > ~/Desktop/audiofix.command <<EOF
#!/bin/sh
sudo kextunload /System/Library/Extensions/AppleHDA.kext
sudo kextload /System/Library/Extensions/AppleHDA.kext
sudo kill -9  `ps ax | grep [c]oreaudio | awk '{print $1}'`
EOF

or

curl https://raw.githubusercontent.com/dashdanw/Handy-Scripts/master/for%20users/audiofix.command > ~/Desktop/audiofix.command

followed by

chmod 775 ~/Desktop/audiofix.command

to make it executable.

You can double click it any time you have the issue and it should work, does for me!


It's just 3 commands that you can read in plaintext so no worry for viruses, you can view the script that is downloaded by visiting the page itself:

https://raw.githubusercontent.com/dashdanw/Handy-Scripts/master/for%20users/audiofix.command

and if you want to get really fancy you can figure out a way to run it on wakeup!

  • Does this still happen to you? Hasn't happened to me since 10.9.2. Also your grep command probably doesn't need the square brackets. Lastly I'm curious if coreaudiod responds to -1 over -9 by reloading itself. – dlamblin Jun 19 '14 at 3:58

I suggest trying to restart the CoreAudio service:

sudo kill -9  `ps ax | grep [c]oreaudio | awk '{print $1}'`
  • Did you mean grep coreaudio or grep [cC]oreaudio? I was able to kill without -9 and it did not bring my sound back. – dlamblin Mar 9 '14 at 3:48

I had the similar problem before. I’m not sure whether 10.9.1 or the settings I’ve made in the Audio MIDI Setup fixes this issue. Try to change Built-in Output format to 44100.0 Hz and 2ch-24bit Integer

Audio MIDI Setup on Mac

Since making changes in the Audio MIDI Setup won’t bring harm to your Mac, you might give it a try and see if the problem persist.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.