0

I'm on my school laptop (MacBook Air) and it used to connect to my home Internet connection but suddenly it just..stopped.

It says that I am connected. And I have full bars, my iPad and everyone else's computer is connected and are working, but my laptop won't.

It's only my home internet too. It connects fine to my schools internet and all my friends internet. But not mine!!! Again I am fully connected but my browsers never load the home page (AND my Spotify won't connect but that's not that important).

  • Hi welcome to AskDifferent. Please read the Question section of the help page, this will help you structure your question in a way that is easier to answer. If you could provide more information as to the version of OS X you are running as well as what troubleshooting steps you have undertaken etc. that would be very helpful. – Deesbek Jan 29 '14 at 2:52
1

From your question we can assume that you are connecting via WiFi and the WiFi icon on the menu bar is telling you that you are well connected.

The next step is to make sure you are getting a valid IP address. Open System Preferences > Network and click on the WiFi connection on the left. On he right it should now say something like "WiFi is connected to AccessPoint and has the IP address 192.168.1.21". There should also be a little green button next to the WiFi in the left hand pane.

If that is all ok then open "Terminal" and type "ping -c 2 www.google.com" and see if it then types

PING www.google.com (74.125.237.179): 56 data bytes
64 bytes from 74.125.237.179: icmp_seq=0 ttl=58 time=27.140 ms
64 bytes from 74.125.237.179: icmp_seq=1 ttl=58 time=24.797 ms

--- www.google.com ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 24.797/25.968/27.140/1.172 ms

you know the network appears to be working well and the problem might be your browser.

| improve this answer | |
0

A couple of possibilities

  • Go to your Apple menu and check that the location is set to Automatic: so >Location>Automatic. It can be set to other things - for instance, I have locations set for each of my clients where I need a fixed IP address. But for most people, it should be set to Automatic.
  • Once you've checked that, do the stuff that Tony talks about.

We need to know whether anyone else can join your home network and experience the same problem. And it would be good to know exactly what happens.

I'm going to take a wild guess: go to >System Preferences…>Network.

Click on Advanced

Click on the tab DNS

In the pane DNS Servers there should be at least one TCP/IP address and it should be something like 192.168.0.1 or something of that ilk.

The DNS should be set to the same as your router address, but it might not be. In any case it should be in grey as it should be supplied by your router.

That's part one of the answer. The next response will describe how I have my home network set and it never goes down.

Let us know how you get on.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .