I am running Mavericks on a Mac Mini. I was attempting to move my iPhoto library to a different Mac by copying it onto an external USB drive. The iPhoto Library is 98GB.

I left it running for 3 hours, when I came back it said it had 14 days to complete. So I tried to cancel. The Finder popup said "Stopping..." but stuck there.

I have since rebooted the Mac but Finder says the file is still on the USB drive. If I tried to delete it again it just says "Deleting..." and then Finder freezes.

It seems like the iPhoto Library that I tried to copy is corrupted on the USB drive and now it can't be deleted. Finder says the file is 98GB even though it still had 14 days to run.

How can I get rid of this file?


Try deleting it with Terminal:

rm -rf /Volumes/diskname/path/to/folder

This command will remove (forcefully and recursively) the path given. Be careful when entering the path to ensure you delete the correct folder, as there's no protection against deleting everything. Note that Terminal will show no progress whilst this is being carried out — the prompt will return when it's complete.

| improve this answer | |

If everything else fails, use the disk utility and reformat the USB drive.

You will lose all on the drive, but it is the last resort.

| improve this answer | |

You can attempt to remove the file using Terminal:

rm -rf /Volumes/[DriveName]/[Path]

Or if that fails format in Disk Utility.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .