2

I own an early 2011 MacBook Pro running Mac OS X Mavericks. Recently, I tried to make 50 GB partition using Disk Utility but the whole process didn't complete, and I had to restart the system as it hanged (Even Force Quit wasn't working). Upon reboot, I saw that I was missing 50GB space. When I tried to verify the disk, it showed me the following error:

"Partition map check failed because no slices were found."

Can I fix it without using external drive? Please help.

  • Did the accepted solution solve your problem? – Alan H. Mar 25 '15 at 3:59
  • Plain old reboot then re-try worked for me. – Bohemian Nov 10 '17 at 2:43
1
  1. Reboot into Single User Mode (hold cmd-S on boot)

  2. Run /sbin/fsck -fy

    fsck is File System Consistency checK. -f forces the process, and -y assumes yes.
    This will basically run Disk Utility's Repair Disk, but outside of the OS so that is has full read/write to the disk.

  3. Once complete, reboot

  • Perhaps you can explain what the command does and why running it would help them? – user10355 Jan 28 '14 at 19:48
  • @cksum Added explanation – grg Jan 28 '14 at 19:56
  • @grgarside I am getting the same error message as OP, but on an external drive. (And options to repartition are greyed out.) How might I modify this command to help me? – Alan H. Mar 25 '15 at 3:59
  • How do you target an external drive with this command? – Alex Jun 9 '15 at 17:19
  • 1
    @Alex I've not tried this in single user mode, but once you've mounted the disk, you should be able to do it with sudo /sbin/fsck_hfs -fy /dev/disk1s1 – grg Jun 9 '15 at 17:20
0

Run the fstab command and remove all the setting there, then write the command. What I had there was preventing my Windows BootCamp partition from mounting. After removing it everything worked fine. http://www.cnet.com/how-to/prevent-a-partition-from-mounting-in-os-x/

  • What do you mean by "write the command" – mmmmmm Dec 10 '14 at 15:36
0

I recieved "Partition map check failed because no slices were found.” from Disk Utility but perhaps for different reasons.

I had to reMOUNT (either it's a "right-click" or a button) the partition from Disk Utility and then Repair the partition.

Then it worked - heart attack / data loss averted.

0

I had a similar problem and the following the method of the link below helped me.

https://perrohunter.com/repair-a-mac-os-x-hfs-partition-table/#comment-127930

  • Please give a few details related to the link. – killswitch Apr 5 '16 at 9:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .