First: I'm obviously not talking about logging in and then automatically launching Terminal.app.

In older versions of Mac OS X, you used to be able to type >console in the username field on the login screen and go directly into a command line terminal session.

I haven't done it in years until the other day. However, now, when I try it, my computer just locks up. I can't cancel, and it never sends me to a terminal session.

Is it even possible to do this anymore? If not, does anybody know when it was removed? It seems odd that typing >console would cause the machine to lock up if it wasn't recognizing it in some way.

  • 2
    what OS are you running?
    – Andrew U.
    Commented Jan 28, 2014 at 14:40
  • I have the same problem on a MBA 2013 running OS X 10.9.1 Commented Jan 28, 2014 at 17:31
  • This is Mavericks on a 2012 Retina MBP with a clean install from only two weeks ago.
    – Thrillho
    Commented Jan 28, 2014 at 19:21
  • Strange, the testing I did was with OS X 10.9.1 on a mini, MBP has 10.7.5 and a MB 10.8. Hope someone else has a better clue. Have you tried apple support? Reinstall?
    – Deesbek
    Commented Jan 28, 2014 at 22:06
  • It's a very fresh install with a bunch of developer setup, so I'd prefer not to reinstall. If I can't figure anything out soon, I may try the Genius Bar.
    – Thrillho
    Commented Jan 30, 2014 at 16:04

4 Answers 4


If you find >console not working, newer OS have disabled it by default.

A quick command line modification of the preference will re-enable it:

sudo defaults write /Library/Preferences/com.apple.loginwindow.plist "DisableConsoleAccess" NO
  • 1
    This does not work on 10.12.1 (16B2555)
    – user110537
    Commented Nov 3, 2016 at 19:35
  • Nor does it work on 10.13.2
    – Hoppo
    Commented Jan 29, 2018 at 11:23
  • any solution for Monterey OSX?
    – hasan
    Commented May 4, 2022 at 0:39

>console works on OS X 10.7.5 , 10.8 and 10.9

I have just tested >console and was able to log into the console without issues running the above OS X's.

I would say there is something else wrong with your system if you cannot get to the basic console.

I would also check your console logs and activity monitor as specified here.

  • 1
    The OP could even ssh into their Mac before attempting the >console log in attempt and then tail the system log file! run sysdiagnose when the Mac is frozen and otherwise see what process is stuck or running. My question is what needs to be done in single user mode that you can't accomplish from ssh or terminal app.
    – bmike
    Commented Feb 2, 2014 at 15:45

Another thing you might want to check is if you can boot in single user mode. Single user mode is triggered by holding cmd-s at startup:


The single-user mode environment is quite a bit different than the standard terminal, because you login as root and a lot of system services are turned off, so it is not equivalent to the >console approach.

  • Yep, I can get into Single user mode just fine. If it's any different, my screen now turns gray and then locks up after typing >console at the login screen.
    – Thrillho
    Commented Jan 30, 2014 at 16:02
  • Hmmm. Have you made sure to try it after a full restart, not just a user logout? And just to throw out some more random ideas, have you installed the newest XQuartz? You could also check your tty file to make sure everything looks in order, but be careful that you know how to reverse any changes you make. Commented Jan 31, 2014 at 0:55

I'm having the same issue and can add the following:

sshed into the machine prior to entering >console at the login window.

Entered >console and hit return at the login window.

On the machine that was connected via ssh I ran sudo tail /var/log/system.log which showed evidence of a SecurityAgent crash.

killed (kill -HUP ) the WindowServer process (via ssh) and immediately got a white block in the top left corner of the screen. I hit Return and was at the login: prompt and was able to authenticate and work in console mode.

Subsequent tests have all been the same so in order to access >console it looks as if you need a second machine and ssh access.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .