Recently I have noticed my MacBook Pro is completely discharging when I leave it to sleep. After investigation I've discovered traces similar to the following in the Console output:

24/01/2014 18:35:11.000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
24/01/2014 18:35:57.000 kernel[0]: Wake reason: XHC1
24/01/2014 18:36:01.000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
24/01/2014 18:37:01.000 kernel[0]: Wake reason: XHC1
24/01/2014 18:37:05.000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
24/01/2014 18:37:50.000 kernel[0]: Wake reason: XHC1
24/01/2014 18:37:55.000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
24/01/2014 18:38:56.000 kernel[0]: Wake reason: XHC1
24/01/2014 18:38:59.000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake

And so on and so forth until it eventually kills the battery and it gives up altogether. Obviously this is, er, unhelpful and I'd like it to stop. I've unticked 'wake for network access' in the energy saver settings but it makes no difference. I've disabled 'allow Bluetooth devices to wake this computer' and switch Bluetooth off. I've also unplugged all peripherals before sleep to check it wasn't something else triggering it. I have, of course, tried restarting.

This is a mid 2012 MacBook Pro, currently running OS X 10.9.1 but it was happening with 10.8.4 as well.

Can anyone suggest how I can stop this happening?

Edit: More information, as requested in the comments

pmset -g log | grep wake gives pages of this

24/01/2014 18:33:55 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:35:01 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:35:50 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:36:55 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:37:44 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:38:49 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:39:15 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:40:20 GMT  WakeRequests           Clients requested wake events: None                                                   
24/01/2014 18:41:24 GMT  WakeRequests           Clients requested wake events: None

interspersed with occasional sections like this:

24/01/2014 17:40:47 GMT  Assertions             PID 18(powerd) Created InternalPreventSleep "com.apple.powermanagement.darkwakelinger" 00:00:00  id:0xe000008ff [System: SRPrevSleep kCPU]            
24/01/2014 17:41:02 GMT  Assertions             PID 18(powerd) TimedOut InternalPreventSleep "com.apple.powermanagement.darkwakelinger" 00:00:15  id:0xe000008ff [System: SRPrevSleep kCPU]           
24/01/2014 17:41:02 GMT  Assertions             PID 18(powerd) Released InternalPreventSleep "com.apple.powermanagement.darkwakelinger" 00:00:15  id:0xe000008ff [System: SRPrevSleep kCPU]           
24/01/2014 17:41:07 GMT  WakeRequests           Clients requested wake events: None

You have gotten pretty far and tried several things. Found this gem: http://support.apple.com/kb/PH11080 which has a list of things, some of which you have already done.

XHC1 refers to a Bluetooth device that is trying to wake your system but the fact that you are getting a output of "AirPort_Brcm43xx", the AirPort message pointed me to: https://discussions.apple.com/thread/4645214?tstart=0

And if you have everything unplugged, BT is off and you have disabled the "Wake for network access" then I have a tendency to think that your OS is corrupted. I would go so far as to say that Power Nap is the service is that causing this but hard to say without for logs and I don't have that much free time! ;)

Unfortunately in the Apple discussion there was no marked answer/solution so if the issue still remains after a reinstall or test OS then you might have a hardware issue. You could also try resetting the SMC (http://support.apple.com/kb/ht3964) maybe the AirPort/Bluetooth card and MLB need a quick power cycle via the reset.

Hope that helps in some way.

  • After an SMC it seems to be okay but it doesn't do it every single time anyway so I'll give it a few days before declaring it fixed. – Jack Aidley Jan 28 '14 at 13:56
  • Sadly, it's back to doing it. The SMC reset didn't fix it. – Jack Aidley Jan 30 '14 at 11:58
  • And reinstalling the OS? Have you tried that yet? – Andrew U. Jan 30 '14 at 12:00
  • No, I haven't. How much re-installing of software, etc. will that involve on a mac? – Jack Aidley Jan 30 '14 at 12:09
  • If you re-download the OS from the Mac App Store and then launch the installer you shouldn't have to reinstall any apps, maybe just some plugins or java/flash but you will be done in an hour from start to finish :) – Andrew U. Jan 30 '14 at 12:46
up vote 3 down vote accepted

I eventually figured this out, and the Airport thing was actually a red herring: that message simply pings up as it comes out of sleep.

It seems there was a two fold failure. The first was fixed by resetting the SMC but the problem continued, albeit less persistently. However, whatever issue the SMC was causing was hiding the second issue: something about the keyboard I have plugged in is triggering it to wake from sleep. Because the SMC was causing it to wake regardless I didn't pick this up when I was first checking for peripherals waking it.

So there you go. Thanks to everyone who helped.

I haven't figured out a way to solve the problem properly yet, I just have to remember to unplug the keyboard.

  • Having the same problem. I'll try turning off Bluetooth first before sleep. It may just be the cleaner disturbing my Apple Trackpad in the morning. – Foliovision May 18 '17 at 19:13

Open AirPort Utility → Preferences and uncheck Monitor AirPort base stations for problems.

  • Unfortunately, I've already done that. Bluetooth is also switched off. – Jack Aidley Jan 28 '14 at 11:52
  • @Jack See edit. – grg Jan 28 '14 at 12:04
  • Unfortunately I've dove that too. – Jack Aidley Jan 28 '14 at 12:05
  • 1
    @Jack Try posting the results of pmset -g log | grep Wake – grg Jan 28 '14 at 12:17
  • Okay, I've added that to the question. – Jack Aidley Jan 28 '14 at 14:00

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.