7

I picked up an external hard drive a while back and have been using it for Time Machine back-ups. Recently I thought to confirm that the disk is encrypted so that it won't be useful if someone nicks it while I'm gone, but it wasn't, and the check box to make it so is disabled.

The disk is using HFS+ (Mac OS Extended (Journaled)) as its file system. The only thing "weird" that I can imagine that might be causing this is that I'm not using the whole disk for back-up; it's about four times larger than my internal SSD, so I just partitioned half to use as the Time Machine partition and intend to use the other part for general storage (once I have something I need to store on it). Does Time Machine need the whole disk to do encryption? I tried selecting the empty partition to see if it would make an encrypted back-up on there, but still, no dice.

If I have to repartition the entire disk to be able to do encrypted back-ups, I will, but I'd like to ensure that that will do any good before I do so.

If partitioning isn't the problem, any suggestions for figuring out what the real one is?

  • What OS version do you have and how is your mac connected to the external drive? – Andrew U. Jan 28 '14 at 8:30
  • Mavericks (as per the title :P ) and USB. – Garrett Albright Jan 28 '14 at 23:20
9

According to this page: http://support.apple.com/kb/PH11102

If the Encrypt checkbox is available, you can select it to keep your backup disk secure. If the Encrypt checkbox is dimmed, your backup disk doesn’t support encryption.

Encryption is available only for Time Capsules and for partitions or disks attached directly to your computer and partitioned with the GPT partition scheme. If encryption is not available for your disk, put the mouse pointer on the dimmed checkbox, and after a moment an explanation appears. If a disk needs to be reformatted or repartitioned to support encryption, Time Machine prompts you to do so.

So check and see what the mouse has to say about why it is dimmed out the encryption option. It could well be that you need to reformat the drive

  • 1
    Thanks. It looks like the partition scheme was indeed the culprit. I had assumed the correct scheme had been chosen for me automatically when I partitioned and formatted the disk after buying it, but instead a PC-friendly one had been chosen (the disk was originally formatted as FAT-32). I re-partitioned the disk being sure to choose the correct scheme (use the Options… button under the Partition tab in Disk Utility), and now things are working as expected. – Garrett Albright Jan 29 '14 at 1:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .