1

I have an issue where a book of mine doesn't seem to want to download at all. I purchased the book from the iBooks store. At a couple points in the past the specific book in question was deleted off my iPad for some reason. However I was able to both times go to my purchases and re-download it on the iPad and iPhone and my reading position was even preserved.

However on my Mac, it appears to be in an inconsistent state. The book shows up as not being downloaded at all.

enter image description here

so then I try and download it and it appears to download 99.99% of the book, but then quickly shows this dialog

enter image description here

When I look in the downloads folder for iBooks it appears to be mostly (if not all) there, but I keep consistently getting that dialog every time I try and re-download the book.

enter image description here

Since this is from the iBooks store and iBooks thinks its not downloaded, it appears to disable deleting the book (for some reason.) So I can't just delete it and then re-download it. Has anybody encountered anything like this and have any suggestions for how to finally get iBooks to re-download this book in its entirety? I think I should probably also file a radar with Apple asking for the ability to delete books in this state (if it isn't a bug.) Thanks.

2

I have never had only problems with iBooks. But when downloading 'Get Sample' of your book "designing bsd root kits" the same error occurred!

It is likely that this book is corrupted in the Store. Give Apple a call and see what they can do. This might not be your fault at all.

download ibooks failed

  • ... mmm I am a little late ... – CousinCocaine Aug 14 '14 at 10:45
  • Hmm thanks. Im not sure where to report this to Apple, but I'll look around and see. Many Thanks for verifying the sample of the book is corrupt. – Colin Wheeler Aug 20 '14 at 3:46
1

I managed to replicate your problem but just a quit of iBooks, wait a few minutes and then run the app again cleared it.

I also found that clicking on the download arrow at the right of the toolbar shows a list of the books awaiting download. Clicking on the orange try again icon made the hung file disappear from this list.

Have you tried deleting it from the iBooks download folder and then re-trying?

  • I have tried quitting and re-launching many times. I also did completely delete the download files on disk and then re-launch the app and tried again to no avail. Again the progress bar gets almost all the way done and then says there was an issue downloading the book :( – Colin Wheeler Jan 28 '14 at 3:42
0

Well I thought i'd post a follow up and the eventual solution to this weird problem. So I did end up contacting apple, and they did try to help me solve this issue, however nothing really helped on OS X. I was about to try and see if I could extract the file of the book off my iphone, but before I could do that OS X 10.10 Yosemite came out. I tried once again to see if this would solve my issues and amazingly this time iBooks downloaded this book and now I can read it just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .