44

I had an bluetooth audio device (Bose SoundLink Wireless Mobile speaker) remembered on my MacBook Pro running OS X 10.8.5. Now I don't have it anymore and I want to link it with another audio device and it seems to be unable to forget the Bose one and link with my current device, how could I erase the Bose device?

3 Answers 3

79

In System Preferences > Bluetooth, make sure that Bluetooth is on and the Show Bluetooth in menu bar check box is checked. Then hold down alt or option before clicking the Bluetooth toolbar menu icon. Now, in the device's contextual menu you can remove it.

Screenshot showing where and how to click

5
  • 2
    I had a couple devices in the menu that weren't shown in the bluetooth preferences, and this was the only way to forget them.
    – Woahdae
    Jan 26, 2015 at 19:25
  • Thanks a million for this. Somehow this is the only way that works.
    – dyve
    Oct 12, 2015 at 14:45
  • What a simple and exact solution! It works perfectly. Nov 12, 2015 at 3:13
  • 1
    When I thought about the time I've been trying to delete old devices from System Preferences > Bluetooth... why on Earth does the Mac need to pair first with a device we want to delete?! And of course that device will fail, and we're left without an option to forget/remove it :-P Fortunately, your solution worked flawlessly to me... Thanks so much. May 18, 2016 at 16:11
  • The devices will just keep reconnecting the next restart, this is just a temporary solution doesn't solve the original question as to permanently removing the device. At least as of 2019.
    – tmarois
    Sep 29, 2019 at 15:02
21

In extreme situations sometimes the options mentioned so far do not work. If you are having troubles removing the device you can delete

/Library/Preferences/com.apple.Bluetooth.plist

and reboot. This will remove all bluetooth devices and you can then add the ones you want back by pairing them again. I wouldn't recommend this option if you don't understand clearly how to delete the file and how to pair devices. In other words, don't do it unless you know what you're doing.

Using the terminal:

sudo rm /Library/Preferences/com.apple.Bluetooth.plist && sudo shutdown -r now
4
  • 2
    I managed to solve my problem by doing this and also clearing all the recent and connected devices by removing the entries under <user>/Library/Preferences/ByHost/com.apple.Bluetooth.<longnumber>.plist
    – Raykud
    Apr 25, 2016 at 18:14
  • I am having the same problem - clicking the cross to try to delete will only attempt to pair the device (in this instance a PS3 controller)
    – Zabs
    May 1, 2016 at 20:26
  • I couldn't find in global path /Library/Preferences but found this file in user context and this had decided my problem :thumb_up:
    – Max T
    May 28, 2020 at 9:42
  • This method fixed a problem I was having playing audio through a Bluetooth headset that sounded like interference, but I don't think was interference, as the same headset in the same room worked perfectly well with another Bluetooth device. Jul 10, 2020 at 14:24
9

Go to System Preferences > BlueTooth and you will have a list of the devices remembered by the Mac. When BlueTooth is on you can select one and then at the right of the selection will be an 'X' icon. Click on it and the item will be removed from the list. bluetooth prefs For reasons that escape understanding you can only do this when BlueTooth is on.

8
  • 1
    Thanks I did try this before and actually succeeded on it, but each time I open the browsing device ap, the Bose device is still there, even if in my preferences-bluetooth its not, thats the weird part of it, so I'm still not able to forget this device so I can use another
    – Luis
    Jan 27, 2014 at 13:14
  • What application are you seeing it in? Jan 27, 2014 at 13:24
  • 13
    Clicking this X just makes it try to pair with the device for me. It doesn't delete it.
    – Almo
    Oct 29, 2015 at 7:39
  • 3
    Same as @almo. For those who have this problem, the most-voted answer works. Seems like an OS X bug, anybody cares to report it through bugreport.apple.com? Apr 7, 2016 at 11:25
  • 2
    Same as @almo — only the most-voted answer will work. Tested on Mac OS X 10.11 Beta (15A278b), so future versions might work. May 18, 2016 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .