I've scoured the internet to try to find a solution to this bizarre problem (similar problems here and here and here), but have unfortunately failed so far. I'm running OS X 10.9.1 on an early-2013 retina MBP, and my Magic Mouse and Bluetooth Keyboard disconnect every 1–3 hours, causing the following kernel errors:

1/26/14 12:09:23.000 AM kernel[0]: [BNBMouseDevice][waitForData][7c-6d-62-f4-b0-ee] Timeout waiting for data
1/26/14 12:09:23.000 AM kernel[0]: [BNBMouseDevice::getExtendedReport][80.14] ERROR: [BNBMouseDevice] getReport returned error e00002d6 for reportID 0x0030
1/26/14 12:09:23.000 AM kernel[0]: [BNBMouseDevice][getBatteryState] Couldn't get battery state from device
1/26/14 12:09:26.000 AM kernel[0]: [IOBluetoothHCIController][handleACLPacketTimeout] -- Disconnecting due to device not responding (ACL Packet timed out) for connection handle 0xd 
1/26/14 12:09:26.308 AM loginwindow[59]: Preferred Localizations total: 1 contents (en)
1/26/14 12:09:29.000 AM kernel[0]: [IOBluetoothHCIController][handleACLPacketTimeout] -- Disconnecting due to device not responding (ACL Packet timed out) for connection handle 0xc 
1/26/14 12:09:29.000 AM kernel[0]: [BNBMouseDevice][waitForData][7c-6d-62-f4-b0-ee] Became inactive waiting for data
1/26/14 12:09:29.000 AM kernel[0]: [BNBMouseDevice::getExtendedReport][80.14] ERROR: [BNBMouseDevice] getReport returned error e00002d7 for reportID 0x0060
1/26/14 12:09:29.000 AM kernel[0]: [BNBMouseDevice::createUsedVoltagesDict][80.14] ERROR: Unable to get calibrated battery thresholds report for product ID 781
1/26/14 12:09:29.000 AM kernel[0]: [BNBMouseDevice] notice: _outstandingIO > 0 but isInactive() returned TRUE...
1/26/14 12:09:29.000 AM kernel[0]: [AppleMultitouchDevice::willTerminate] entered
1/26/14 12:09:29.000 AM kernel[0]: [AppleMultitouchDevice::stop] entered

Additionally, the Bluetooth panel in System Preferences freezes up completely and shows glitchy information:

Glitchy Bluetooth preferences

The only way to get the mouse and keyboard to reconnect (and the only way to get the Bluetooth panel to work again) is to:

  1. Turn all the peripherals off
  2. Put the computer to sleep (without closing the lid)
  3. Wait for 60–90 seconds for the computer to magically wake itself back up
  4. Turn on the peripherals. All is well.

If I put the computer to sleep with Bluetooth working, it will stay asleep. If I put it to sleep after the peripherals disconnect, it will wake up automatically after a while.

I have no idea what is triggering these disconnects. They don't happen at the same intervals (sometimes it happens after an hour, sometimes four), but they always happen. Since upgrading to Mavericks I've had to do this whole put-the-computer-to-sleep thing several times a day. This did not happen under Mountain Lion.

I've tried the following things, without success:

  1. Reset SMC
  2. Reset PRAM
  3. Deleted ~/Library/Preferences/com.apple.bluetooth.* and /Library/Preferences/com.apple.bluethooth and anything else related to Bluetooth
  4. Reinstalled Mavericks
  5. Had the physical Bluetooth controller replaced by Apple (just got the computer back yesterday)

Despite all this, the problem persists. I still have to put the computer to sleep 4–5 times a day to get the mouse and keyboard working again. Seemingly nobody knows how to fix it—it has even stumped Apple.

Does anyone know what's going on?

  • I have the same issue, the only way for me now is to restart the machine
    – tszming
    Commented Mar 1, 2014 at 11:15
  • Do you have anything nearby that is causing interference? A wifi router, microwave, portable phone base station? I had to switch my router (which is about 3 feet from my mini) to 5ghz and then bluetooth became a lot more reliable...
    – Dave
    Commented Mar 2, 2014 at 3:02
  • Nope. It happens regardless of where I am (home, the office, hotel rooms). The only trigger I've been able to find is Mavericks. The same computer on Mountain Lion had none of these issues—they all started the day I upgraded.
    – Andrew
    Commented Mar 2, 2014 at 3:29
  • For what it's worth, my 2013 RMBP has severe WiFi issues when bluetooth is turned on. I wonder if you turn off WiFi if that makes your bluetooth issues go away. I have reported my bug to Apple at developer.apple.com/bug-reporting and you seem to have enough technical detail to report yours if you so wish. I'll keep my eyes peeled for any better solutions than choosing to power on only one 2.4 GHz emitter rather than both on this model Mac.
    – bmike
    Commented Mar 6, 2014 at 18:33
  • Related: apple.stackexchange.com/questions/110229/…
    – nohillside
    Commented May 25, 2016 at 5:58

6 Answers 6


I was able to overcome the problem with this quick fix. So whenever you loose bluetooth connectivity just run the following commands in the terminal

$ sudo kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport
$ sudo kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport

You will regain connectivity.

  • This is it. This fixes it perfectly. You can put the two commands in a bash script (like this) and run it whenever with sudo bt-fix
    – Andrew
    Commented Oct 2, 2014 at 18:21
  • 3
    This no longer works in Yosemite…
    – Andrew
    Commented Nov 26, 2014 at 0:35
  • This fixed for me in Yosemite. For now. I used to loose magic mouse connection all the time and had to restart. Now ... hopefully will work for future Commented Mar 6, 2015 at 1:54
  • None of these commands work for me anymore in Sierra. But this voodoo does: apple.stackexchange.com/a/157317/68662
    – Andrew
    Commented Nov 8, 2016 at 1:34

I had the same issues and I was able to fix it by deleting the bluetooth settings as Andrew suggested in 3, in combination with also killing the preference cache (see http://reviews.cnet.com/8301-13727_7-57617236-263/how-to-tackle-defaults-not-sticking-in-mavericks/). Without killing the cache daemon, I wasn't able to solve the problem. So here's what I did:

rm /Library/Preferences/com.apple.Bluetooth.plist
killall -u yourusername cfprefsd

If I remember correctly, I issued both commands multiple times to make sure all Bluetooth settings.

Hope this helps!

  • Oh, I was so optimistic that this would work, but I've tried it 3 times and the problem continues. Rats.
    – Andrew
    Commented Mar 23, 2014 at 0:02

I have the same issue routinely. I solve it by opening the "Activity Monitor", Selecting the "kextd" process under the CPU tab, and quitting the process. It will immediately restart and bluetooth connectivity is restored. This is more of a workaround than a fix but is quick and effective for me. enter image description here


My Airpods Pro would not connect to my Mac. The above solutions did not work for me. Seeing this in the console: default 11:35:44.718199-0500 bluetoothd found name string in EIR! it is: Christopher’s AirPods Pro

I noticed the funny characters that appeared instead of the ' (apostrophe) that was expected. It should have read Christopher's AirPods Pro.

I was able to connect the airpods to my phone. Using my phone I changed the name of the Airpods to "Chris Airpods". Hoping this name change might stick across my icloud connected devices.

Sure enough, after the name change I was able to connect to them on my mac. Might not have had anything to do with the non-letter character, maybe just re-naming refreshed some cache, I don't know. But it worked. Previously it had failed with error: default 11:35:48.566256-0500 com.apple.preferences.Bluetooth.remoteservice Pairing with Christopher’s AirPods Pro failed with e00002d7


My bluetooth speakers kept connecting and dropping every 15 - 30 seconds (Macbook Pro retina). Speakers were fine, tried them on iphone.

Tried all the other suggested fixes, Reset PRAM, reset bluetooth module, run scripts but nothing worked. I found a fix though.

Turn off your bluetooth device. Pair your mac with your iPhone. No connection required, it said it wasn't supported. Then reconnect to bluetooth device (speakers). Connection has yet to drop. Good luck.


My it helps you to reset the SMC (System Management Controller), as the SMC is responsible for all components that are associated with power supply and, according to an Apple Store Genuis, a SMC reset would reset the bluetooth chip as well.
(Here is the link to Apples Support Page with a tutorial to reset the SMC)

  • Since the OP already states they reset the SMC, you might comment and ask if the SMC reset they did complies with the link you provided.
    – bmike
    Commented Mar 5, 2014 at 14:00
  • And it does :) I've reset it, and Apple has too, to no avail…
    – Andrew
    Commented Mar 5, 2014 at 14:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .