I have a MacBook Pro 15" with retina display that I use for work/personal stuff and I always shut down with Wifi having been on. When I startup my Mac the Wifi icon looks like it's searching and never actually connects (most of the time). To get it to connect I have to turn of Wifi (on my MacBook, not the router) and turn it back on, then it connects pretty much right away. What's the issue here? It's very annoying.

  • For as long as I can remember, I've had to do this on my MacBook Pro Retina 15″ — I've always presumed it's the router, as I only have the problem at home. I even have a script that will automatically cycle the Wi-Fi if it's attempting to connect to my home network and fails for more than 3 seconds :)
    – grg
    Jan 26, 2014 at 20:00
  • I have this problem at work and home. It started happening after the Mavericks update so I don't think it's the router. Jan 26, 2014 at 20:44
  • I agree with @grgarside. I'm not sure if it's a Mac issue or a BSD issue, since Linux boxes also have an issue with it, but WiFi devices (internal/usb) seem to have issues with connectivity. Older OSes required restarting the machine to resume connectivity (not just restarting the WiFi software, like you can do with Mac).
    – BotNet
    Jan 26, 2014 at 21:17
  • @grgarside - Can I get a copy of that script please? I made a question for it here (apple.stackexchange.com/questions/150722/…) .. Much appreciated! Oct 15, 2014 at 23:27

9 Answers 9


Old preferences hanging around after upgrade can cause issues. To force a rebuild of the preferences open Terminal and do:

cd /Library/Preferences/SystemConfiguration
sudo rm NetworkInterfaces.plist
sudo rm com.apple.airport.preferences.plist
sudo rm preferences.plist

then restart your machine.

  • I have to do this every three days for it work properly.
    – Trip
    Apr 7, 2016 at 12:39
  • Actually this fixed issues I had with my macbook's keyboard and trackpad not working, too.
    – kris
    Jul 26, 2017 at 18:53

What actually helped was to reset the SMC and reset the PRAM. Now the Mac connects instantly to the WiFi.

Later edit: It looks like the problem is caused by interference from Bluetooth signals and your WiFi device. Because it connected much faster with Bluetooth off. I changed to a 5Ghz network on another WiFi AP and I had no problems since.

The following are all suggestions I've tried from different sources:

  • Can you add steps for resetting the SMC and PRAM? Jun 24, 2014 at 22:08

Try this Golang script out - https://github.com/icecrasher321/Wifi_Hack

The script automates the process of turning off and on your wifi at intervals of 20 minutes(Future versions will detect packet drops to start the wifi reset process). You can keep it running in the background. More information is available in the README of the github link given above.

If you don't want to install Golang just for this, you can get the same result by using the following shell script


while :; do
    networksetup -setairportpower en1 off
    sleep 3
    networksetup -setairportpower en1 on
    sleep $((20 * 60))

Run networksetup -listallhardwareports first to check whether your Wi-Fi really is on en1 .

  • 1
    Link-only answers usually aren't that helpful to begin with, and loose any value in case the link target disappears. In addition Golang is not part of OSX so some additional information about what the script does and how to get it working on a standard OSX install would be helpful.
    – nohillside
    Aug 4, 2016 at 7:15
  • Apologise for the crude answer. Answering your question - The script automates the process of turning off and on your wifi at intervals (you set). You can keep it running in the background. More information is available in the README of the github link given above. Aug 5, 2016 at 14:09


Try removing some of the plist files as indicated in the above

  • More elaborated answers are expected here, not just a single URL which could get offline and thus, making your answer useless. Consider editing the answer, adding some of the most relevant information from the URL you posted, and, perhaps, explaining why this could solve the issue the OP has.
    – Thecafremo
    Jan 27, 2014 at 9:54


  1. Turn off your router.
  2. Start your mac.(now it should start without problems)
  3. (remove all your wifi network configs. Create new ones)<- it doesn't work for me.
  4. Preferences > Disable in IPv6 in network preferences!!!

Also, try to update/reinstall tap/tun virtual network drivers. Install the version for your OS at http://tuntaposx.sourceforge.net/download.xhtml


Look at your antivirus settings , i had to check my settings on avast (antivirus program) and realized that a " web shield " was enabled , once i disabled it . Web pages started loading. Ps : i was a few days without loading webpages on my laptop before trying this. I hope this helps :)


I wrote this script that checks for internet every 20 seconds then restarts the wifi network adapter if it is offline. You may have to change your adapter from en0 depending on which one your WIFI device uses


    while :; do

    echo -e "GET http://google.com HTTP/1.0\n\n" | nc google.com 80 > /dev/null 2>&1

    if [ $? -eq 0 ]; then
        echo "Online"
        echo "Offline"
        networksetup -setairportpower en0 off
        sleep 3
        networksetup -setairportpower en0 on

        sleep $((20*1`))
  • Are you sure about the backtick in the second sleep command (you actually could just sleep 20 here anyway)?
    – nohillside
    Nov 10, 2020 at 14:40

In my case, the only thing I found to actually fix the problem was to change country settings in my router to USA.

Routers and Wireless interfaces have different "profiles" for different world region due to regulations that change between country to country.

In my case I suspect that someone have some buggy implementation on their side (maybe my router, maybe my MacBook Pro).


I had been having issues with my internet on my late model 2015 MacbookPro for months and turned off the Bluetooth and the difference was night and day. I have about 6 different devices that the Bluetooth has been connected to on and off over the course of two years. I recently had it serviced at Apple for another issue where the PRAM was reset and saw no change. Will post a follow up if anything changes but I am amazed at the difference so far.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .