2

Basically I have my iPhone w/ iOS 7.0.4 jailbroken using the latest evasion software.

I recently ran out of battery, and when I had managed to recharge and get my handset back on, all of my apps (apart from the stock apps that come with the phone) are all gone. No other data is missing, e.g , music, pictures and videos.

When I go to, settings, general, and usage. I can clearly see that my memory is still being taken up by all the apps I "had" on my phone (2.1gb free) yet the apps still aren't there. I'm usually good with tech, especially Apple. But this one has me stumped.

  • Did you reboot your device? Sync it with iTunes? – Rob Jan 26 '14 at 18:30
  • I have rebooted several times. I never use iTunes with my iphone so I don't see how that would matter, but I shall give that a shot. Thanks for the comment. – Ferguson87 Jan 26 '14 at 18:38
3

It's a bug. Your apps aren't gone but just not visible on your Home Screen.

To restore them, reinstall a package through Cydia (either an existing one, or a new one will suffice). Then either respring (can be achieved via WinterBoard) or reboot your device (unnecessary if you reinstall a package that requires SpringBoard to restart, like ClassicDock for example).

I have unfortunately not been able to pin down the exact cause of this.

  • Unless I am misunderstanding you, then your instructions aren't working. I went into cydia, touched on something simple. (Was just a theme) went into winterboard, applied it, then resprung to no avail. – Ferguson87 Jan 26 '14 at 22:24
  • @Ferguson87 In Settings > General > Usage, are your apps still listed? – user10355 Jan 27 '14 at 8:47
  • No. Again only the stock apps are showing up there. Yet like I have mentioned, my memory says otherwise. I have 2gb free. – Ferguson87 Jan 27 '14 at 9:12
  • @Ferguson87 I would SSH into your device and check out the contents of /var/mobile/Applications/. Apps are installed to this location (into long strings, like 03DAC015-D38D-4F5A-B3BF-8C65591DB52A). Note that this isn't empty by default. Some apps are installed by iOS. But if you don't see any of your apps, then they are gone. If, however, they are still there, then it's likely an issue with SpringBoard (and we can look into perhaps other ways to restore them). Let's just gather more data first. – user10355 Jan 27 '14 at 10:39
  • It's safe to assume that they will be there. If we are going to go as far as to look at the root directories, then my assumption is they would defo be there as in my memory shows that the space is being taken up. So I think we can move forward from the debate "are they there/installed or aren't they" they are defo there. Just not showing. – Ferguson87 Jan 27 '14 at 17:59
1

This is the third time I've had this issue: the very first time I ended up restoring my iPad. The second time it happened I ended up re-downloading all the apps but noticed that the apps that were in the folders were getting downloaded but also re-creating the same folders that they were in and going in there.

I now found I solution:

  1. Download iFile from Cydia
  2. Navigate to /var/mobile/Library/Caches and delete com.apple.mobile.installation.plist
  3. Shutdown the iPad by holding down the power button and then swiping it to power off
  4. Reboot *If deleting that file did not work, try also deleting 'com.apple.mobile.installation_backup.plist'*

This method is the fastest way to restore the missing apps. It restores also the data in those apps. Note: (the folders will not be restored only the apps). It works only if you lost your apps during reboot/restart (bug).

0

If you have SSH access to your device (as mobile user), run uicache then respring.

The command provides no Terminal output once complete, just wait for the prompt to return then respring. It takes a few seconds to carry out the command.

-1

I know this will be a pain for all iOS people( me included ) but I worked out that if I just left my iPhone (4 iOS 7.0.4) alone for a while it would do a respring or something that looked like a respring at least then all my apps wer back. I wonder if it could be a substrate bug coz before sauric updated it I did the same thing so if anyone knows more about the substrate u might want to look into it

  • What do you mean left it alone for awhile? – Ferguson87 Jan 27 '14 at 9:10
-2

For me ipad 2 ios 7.4 after 2 Times of this fritz led to to rejailbreak 2 I uninstalled cydia substrate removing every tweak did I get my icons back! I think it's scrambled or broken extensions to lib hide but really it's all still forced together!

You must log in to answer this question.

protected by Community Feb 4 '14 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .