I have this early 2008 MacBook 13" which only is upgradeable to 10.7.5.

I checked on the app store and it says Xcode requires OSX version 10.8.4 Mountain Lion and later. Although this page from Apple Dev Center says the requirement is Snow Leopard 10.6.8 and later.

Is this MacBook sufficient for iOS development,and if so, what iOS version does it support?

2 Answers 2


If you want to develop apps for iOS 7 or later, you need to have the Xcode 5+ with Mountain Lion or Mavericks. Snow Leopard or later is required to run Xcode 4+.

  • Xcode 4+ == iOS 5, 6
  • Xcode 5+ == iOS 6, 7

Incorrect. You need the latest Xcode if you're going to submit the app to the app store. If you're developing for personal use or to learn, Pratik's advice is okay. If you're going to develop and ship, you'll need a friend who can run the most recent Xcode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .