4

For about a year now I have not been able to print handouts in Microsoft PowerPoint 2011 (14.3.9). The option is simply not in the print dialog box. I finally discovered that this is due to using a case-sensitive file system. What I see is the following:

PowerPoint print dialog on a case-senstitive file system

I can use the Layout options to accomplish a similar effect, but I can't print handouts with notes, etc. It turns out that this problem affects all of Office (Word and Excel as well).

What I should see is

PowerPoint print dialog on a case-insensitive file system

Other than reformatting my hard drive as case-insensitive and restoring from my Time Machine backup, is there any way to correct this behavior?

EDIT: Please note that in the first dialog, Apple's default "Copies" and "Pages" options are displayed above the pop-up menu. In Microsoft's print dialog extension (second image above) Word, Excel, and PowerPoint present their own "Copies" and "Slides" and "Print What" (etc.) options under the "Copies & Pages" pop-up. There simply is no "Copies & Pages" option when running on a case sensitive file system, so there is no way to print handouts, speaker notes, etc. Case sensitivity apparently causes the Office print dialog extension to fail to load.

I've used otool to dig through the dynamic libraries and frameworks involved, looking for a possible case mis-match, but so far have come up empty.

EDIT 2: There simply is no "Copies & Pages" option in the popup dialog on a case-sensitive file system, I've attached a third image that shows the options available to me:

enter image description here

It is simply not there. As stated in the previous edit, they are above the pop-up menu. In fact, PowerPoint ignores the settings there, since it is expecting the options from the custom plugin Office provide. So I can ONLY print a single copy of a full document, unless I jump into Preview first.

4

I just solved this on my own machine. Very frustrating.

The issue is that the missing section of the print dialog is a "Print Dialog Extension" (PDE). This is loaded from the individual Office apps' plugin directories. The issue is that Office is coded to look for a "PlugIns" directory whereas the directory is actually named "Plugins".

I suggest using a symbolic link to fix this. Presuming you have a default installation of Office then open Terminal, and execute:

cd "/Applications/Microsoft Office 2011/Microsoft PowerPoint.app/Contents/"
ln -s Plugins PlugIns

Relaunch Powerpoint and bask in the delicious print dialog extensions. BTW, you will need to do something similar for the other Office apps.

NOTE: I advise against simply renaming the Plugins directory to PlugIns. It might break something else.

  • Thank you! I knew it had something to do with the PDE and was digging through the plug-in with otool to try to find a mis-matched path. This is exactly what I was looking for. – ithos67 Feb 16 '14 at 22:51
  • For completeness, this is the fault of Microsoft. Apple's documentation states "An application PDE should be stored in the PlugIns directory inside the application bundle" (note the case) developer.apple.com/library/mac/documentation/Printing/… – ithos67 Feb 16 '14 at 23:00
  • @ithos67 There are several ways to profile running apps on Mac OS, but probably the simplest tool for this type of task is fs_usage. That's what I used to identify the incorrect pathname: took a capture while I fired up the print dialog, then parsed through it. – Roadkill Feb 28 '14 at 4:47
  • Seems this problem occurs when using a case sensitive file system. – darwin May 18 '14 at 15:56
  • An alternative is to use "File -> Save & Send -> Create Handouts -> Notes below slides" which will put the slides and notes into a Word document as I found here: iconlogic.blogs.com/weblog/2010/10/… – eric Mar 27 '17 at 18:18
0

Roadkill's analysis is correct, but if you want to convert your volume to a case-insensitive file system (which may be a better long-term solution), the suggestion in the article (to restore from time-machine) will not work.

A Time Machine restore will reformat your hard drive to match the case sensitivity of the backup. The only way that I've found to fix this so far is either a clean install (because you have all day and nothing better to do), or iPartition from Coriolis Software. It's about $50, but saved me countless hours of frustration. Some other software also doesn't like case sensitive file systems (e.g. Steam). There may be other software out there to convert the case sensitivity of an HFS+ volume, but I couldn't find any.

0

Roadkill's fix worked, but it doesn't explain what caused this problem in my case. I had been happily using a case-sensitive 10.10.5 system (both Mac OS X and Office 2011 fully patched) for many years. Then the print menu changed just like the OP. I did NOT just install a new system or reformat my drive. I checked TM backups going back, and even in my oldest backup from 2 yrs ago, they all have the lower-case i which shouldn't work. However, I am sure that in the past 2 years (in fact, in the past 2 weeks) I have definitely used the extended print options. None of this makes sense. :(

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.