I have tried downloading iChrono, unzipping and installing, but I get the following error message:

You can't install the file "iChrono 3.wdgt" because it isn't a valid widget?

The requirements are Mac OS X 10.4 or later, but I have 10.6.4. When I try to install, I get the following error message:

7/09/10 6:46:07 PM  Widget Installer[327]   Can't open input server /Library/InputManagers/MultiClutchInputManager.bundle

After reinstalling the bundle by downloading MultiClutchInput, I stopped receiving error messages in the log.

I noticed that when I unzip the zip file, I receive the following message:

8/09/10 9:30:05 AM  SIMBL Agent[108]    warning: failed to get scripting definition from /System/Library/CoreServices/Archive Utility.app; it may not be scriptable.
8/09/10 9:30:05 AM  Archive Utility[699]    Error loading /Users/chris/Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer:  dlopen(/Users/chris/Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer, 265): no suitable image found.  Did find:
    /Users/chris/Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer: no matching architecture in universal wrapper

Any suggestions on what to do?

  • 1
    Works fine here. Have you tried to download it again?
    – zneak
    Sep 6, 2010 at 2:23
  • @zneak: Several times
    – Casebash
    Sep 6, 2010 at 3:03
  • Is there anything relevant in the Console application?
    – zneak
    Sep 6, 2010 at 5:37
  • @zneak: What do you mean?
    – Casebash
    Sep 6, 2010 at 21:00
  • @Casebash There's an application called Console that resides in Applications/Utilities. Every time an application has something to report, it puts a message there. It updates live, so you could try to install the widget, then see if a new message comes up.
    – zneak
    Sep 7, 2010 at 3:07

1 Answer 1


Ok, so the problem seems to be that you don’t have the MultiClutch bundle in InputManagers.

Multiclutch allows you to assign custom keyboard shortcuts in a given app to a given gesture, for example if you wanted to “swipe” to change a tab in safari or similar.

It works by installing a simple input manager that catches gesture events, looks to see what shortcut you’ve defined for it in the frontmost app (if you haven’t defined anything, it behaves in the standard manner), and performs that shortcut.

I don’t know what iChrono does but you might try downloading MultiClutch (the free little app) because that will surely install the InputManager, if you later “remove” it (by dragging it into the thrash), the Input Manager will stay there and your widget should be able to use it.

Check that you have


… and if you do and it still doesn’t work, try thrashing that bundle (save a copy just in case) and see if you can get a new copy.

UPDATE: Could you create a new user and try to download + decompress + install from that user instead? Logoff and login with the new user.

There might be some weird or incompatible bundle sitting in your user.

UPDATE 2 As an added bonus, you can try to replace your Megazoomer’s SIMBL with the original one. I think you have an old version that somehow is not Universally compatible. To those effects a version was compiled by Mathias Meyer who forked the original version.

You can find his version here (links to zip). Download and uncompress the zip and drop megazoomer.bundle into ~/Library/Application Support/SIMBL/Plugins (overwrite it!)

I’ve taken this information from GITHUB: here

  • I reinstalled the bundle, but it still doesn't work and I don't get a log message any more
    – Casebash
    Sep 7, 2010 at 10:08
  • Now that’s very strange. I’ve just installed the Widget without problems. Have you tried installing other widgets? Any other relevant error you see in the Console that may point where the problem comes from? If you could post the whole (relevant) part of the console to a place like pastebin.com I might be able to take a better look at it. Sep 7, 2010 at 13:28
  • Apparently, there is an error message when I try to unzip the file. Updated the question
    – Casebash
    Sep 7, 2010 at 23:32
  • I tried both of those, but didn't work :-(. Thank you for your help anyway
    – Casebash
    Sep 13, 2010 at 11:12
  • It didn’t work with a fresh user? Sep 13, 2010 at 13:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .