0

Two iPhone's in the house, a model 4 (on iOS 6) and a model 5 (on iOS 7), can not connect to the home WiFi network, but can connect at the Apple shop. All other devices on the home network, including desktops, laptops and Android's, are fine.

The error message is displayed about 0.5 seconds after hitting "Join", and is simply "Unable to Join Network".

Trawling forums the advice seems to be to a combination of resetting the network settings on the iPhone and turning the router and iPhone off and on again in various orders.

However, this does not work.

0

Whilst I have no idea what caused the problem, it was solved in this case by

  1. Disabling security on the Wi-Fi network,
  2. Connecting the devices to the unsecured network (which worked),
  3. Re-enable security,
  4. Connecting the devices to the secured network.

Somehow, this solved the problem and all devices were able to connect normally.

On our TP-LINK router, a reboot was required whenever the security settings were changed, i.e. after steps (1) and (3).

Rebooting the phone's was not required, though I think I may have turned the Wi-Fi on the phone off and on again.

Hope it helps!

  • When you can, please mark your answer as accepted by clicking the checkmark so that people know this question has been answered. – daviesgeek Jan 24 '14 at 3:37
  • Yes; it forces you to wait 2 days. – Alex Jan 26 '14 at 1:20
0

UNplugged my router. Waited a few minutes and plugged router back in. That was all it took! IPhone now has wifi again.

0

I am trying to connect my laptop (Acer) to my iPhone's data using hotspot. When I look on my networks menu, I see the label 'iPhone'. However, when I try to connect to it my laptop, my phone flashes on and off. In the end my laptop will say " Unable to connect to this network". I never used to have this problem. My laptop is a Windows 10 Acer and my iPhone 5s.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .