4

While this seems like a straight forward task, the few methods I've tried so far don't create a USB device that my Dell computer will recognize as a valid bootable USB drive.

Here's what I've tried so far (using a cheap 2gb thumb drive, along with the 64-bit Ubuntu Desktop 13.10 ISO from Ubuntu's website):

  1. Insert USB drive, and format it to MS-FAT32 using Disk Utility; then follow this How to create a bootable USB stick on OS X Ubuntu guide verbatim (update: I wasn't as verbatim as I thought! see comment under accepted answer).
  2. Insert USB drive with existing formatting; open Unetbootin, using the same ISO, create a USB installer disk.

In both cases, when I explicitly tell my Dell computer to boot from the "USB Device", I get an error along the lines of "Can't find valid boot disk; press F1 to try again".

I ended up creating the boot disk with the same ISO using a different computer running Ubuntu, using the Startup Disk Creator -- thus I have confidence the ISO is fine -- but I'm stuck wondering, how can I do this with my OS X computer (currently with 10.8.5)?

3

For me it has always worked (albeit building Mint install usb pen drives DOS MBR partitioned) using Terminal , and as per the instructions on the Linux Mint website (http://community.linuxmint.com/tutorial/view/744), which I copy below:

Using the Terminal

It is really simple. Go to a Terminal and type:

sudo dd if=~/Desktop/linuxmint.iso of=/dev/sdx oflag=direct bs=1048576 Where '~/Desktop/linuxmint.iso' is the name and location of your downloaded image (located at the desktop in this example) and '/dev/sdx' is the target USB drive. If your system doesn't support 'oflag=direct', you can just leave it out as it is simply intended to speed up the process a bit.

Remember, don't include an integer for the USB drive, e.g. '/dev/sdx1', as it would refer to the existing partition on that drive and not the drive itself.

When the USB has been properly created by 'dd', there should be an output similar to this:

sudo dd if=~/Desktop/linuxmint.iso of=/dev/sdb oflag=direct bs=1048576

706+1 records in

706+1 records out

740601856 bytes (741 MB) copied, 91.7024 s, 8.1 MB/s

Hope it helps

  • After looking at your post, I realized that I was including the partition number, so I guess the data was copying over fine but the bootloader was not being set. Thanks for helping find the error of my ways! – Dolan Antenucci Jan 23 '14 at 17:03
  • didn't work for me. I also want to create a bootable USB flash drive with Ubuntu in MacOX and then use this to install on Dell laptop – siddhusingh Sep 27 '14 at 7:40
  • @siddhusingh maybe you could be a bit more explicit. Just "didn't work for me" is a tad short. I have used this method on a number of Dell and HP hardware. – cucu8 Oct 5 '14 at 11:31
  • @cucu8, sorry for brevity over clarity :). Basically I had put .iso file ( Ubuntu image ) on pen drive and while booting I tried to install it from the pen drive. It didn't find it as image. – siddhusingh Oct 6 '14 at 7:37
  • @siddhusingh just plain copying the .iso image onto the pen drive will not work. You have to use dd, as explained above. – cucu8 Oct 6 '14 at 9:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .