I purchased a new ADSL modem/router last week (Belkin Share), and can no longer resolve machine names on my LAN to their respective IP addresses under OS X. My Windows machines and VMs are able to do this successfully. If I ping the IP address directly, it succeeds, but if I attempt to ping the machine name I get 'cannot resolve . Unknown host'. My previous modem/router (DLink DSL-G604T) did not have this problem.

If I look at the DHCP leases on the router, the list includes the machine name, and this coupled with the fact that the Windows machines can resolve IP addresses makes me think this may be an OS X config issue (although I'm not experienced enough with it yet to know exactly what). I tried removing and re-adding the Ethernet connection under Network settings, but that made no difference.

  • 2
    I contacted Belkin to see if they supported Bonjour, and here was their response:- "We understand that you want to know if the Belkin router supports Bonjour protocol. We would appreciate if you please get back to us with the following information to isolate the issue: 1. Please let us know if Bonjour, is a software application, that is present on the MAC computer. If is the software application. We suggest that you please contact your computer vendor and check if any ports need to be open on the router for the software application...." – Cleggy Sep 7 '10 at 20:56

It appears the router doesn't support Bonjour at all (and Belkin support were totally clueless when approached about it), so I've returned it for a refund and am on the hunt for one that plays nicely with Macs.


My Airport Extreme does this too. Try adding .local to the ends of the names of the machines you're trying to reach. This uses Bonjour to look up the names instead of your router's DNS, which should work if the computer you're trying to reach is a Mac. If it's a Windows PC (and using .local doesn't work) try installing Bonjour and seeing if that works.

  • The machines are an iMac and a Macbook Pro, and using .local makes no difference. – Cleggy Sep 5 '10 at 21:49
  • @Cleggy Can you see things like iTunes sharing and AFP sharing from one Mac to another? If so, then Bonjour works and I have no idea why appending .local doesn't work. If not, then your router's not passing Bonjour packets for some reason, in which case I would suggest getting a different router, as this one is more trouble than it's worth. – Kyle Cronin Sep 5 '10 at 22:35
  • I'm no longer seeing iTunes sharing (did work with the old router), and AFP sharing only works using the IP address. This may be a course of action investigating further. The router is a relatively new model, so perhaps Bonjour support is currently incomplete or buggy. If I have no joy, I'll nag the manufacturer before returning it. – Cleggy Sep 6 '10 at 0:21
  • @Cleggy Yeah, with AFP I was wondering if you could see the other computer in Finder automatically. One crazy thing - you mention this is a modem/router, is it possible that each computer is being assigned an external IP? – Kyle Cronin Sep 6 '10 at 0:33
  • Nope. Definitely internal (in the 192.168.2 range). Another odd symptom is that the Mac machines show up in Finder as 'PC Server'. I have emailed Belkin support for clarification on their Bonjour support, but I suspect I may have to take you up on your suggestion, and return it for a more Mac friendly modem/router. – Cleggy Sep 6 '10 at 1:01

Just go to System Preference -> Network -> Ethernet/WIFI -> Advanced -> DNS. Add in search domains ".local" Apply and done.

  • Per another answer (6 years ago), the user already tried using .local domains. This question already has an accepted answer, and since the OP resolved it themselves (6 years ago), it is extremely unlikely they would select your answer (6 years later). – tubedogg Oct 13 '16 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .