I suddenly came across this error when I attempted to do open . to open the current directory in Finder, a command that I use quite frequently:

ysim:~/Downloads$ open .
LSOpenURLsWithRole() failed with error -1712 for the file /Users/ysim/Downloads.

It persisted for a few minutes and went away by itself. I tried googling it but the only two hits I saw had to do with ImageMagick and Automator, neither of which I use. Does anyone know why it happens and how to prevent it?

  • 1
    Since i updated to yosemite ( osx 10.10 ) i get this always when opening more than 6 urls simultaneously – Willem Hengeveld Nov 7 '14 at 9:10

That error means an Apple Event timed out.

error -1712 errAETimeout: the AppleEvent timed out 

You can either open Activity Monitor and look to see if you notice an Application or process that states Not responding or hit option command esc then force quit any non-responding application.

It's possible the application or process was already open and by using open . it tried to launch it for whatever reason. Often it's an Automator or AppleScript that is waiting for user interaction and "times out" waiting.

| improve this answer | |
  • Happened to me when trying to open a PowerPoint file. I had exited PowerPoint before, but not quite, it got stuck somehow. After "force quit"-ting PowerPoint, open somefile.pptx worked again. – Laryx Decidua Jun 8 '18 at 9:06

The solution for me was a reboot. It was almost like I was using Windows 😜

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .