5

Known problem: Mail previews e.g. pdf attachments. I want to see it as symbol. I could right click and choose 'Show as symbol' but I want this as default. The old solution was typing into terminal:

defaults write com.apple.mail DisableInlineAttachmentViewing -bool yes

which seems not to work under Mavericks any more. Does anybody have a working solution for this?

0

4 Answers 4

2

Clive Galeni has created a Mail.app plug-in that sets View as icon to be default:

This update will disable attachment auto preview feature and disable inline attachments when reading messages.

It seems that there are two points of view - when composing email and when viewing.

8

I found this here to disable PDF preview in Apple Mail, and tested in on my Mavericks.

defaults write com.apple.mail DisableInlineAttachmentViewing -boolean true

So your were close.

6
  • That didn't work for me, Mavericks and 7.3 Mail (which I restarted)
    – FooBar
    Commented Oct 3, 2014 at 3:35
  • 1
    Works for me on OS X Yosemite and Mail 8.0.
    – DaPhil
    Commented Oct 4, 2014 at 6:39
  • @FooBar try it again, it works great on OS 10.9.5 and Mail 7.3 on MBA. Probably try it with Mail off first.
    – Ruskes
    Commented Oct 10, 2014 at 16:58
  • Nope, that didn't make it, also with Mail off. But I also read earlier that for some people it fixes the issue, for some it doesn't.
    – FooBar
    Commented Oct 10, 2014 at 20:29
  • Worked for me on 10.10 yosemite. Commented Nov 13, 2014 at 14:53
2

Maybe you should have a look at a tiny plugin written by Clive Galeni. It can be downloaded from

Just follow the instructions and you are good to go. I'm using OS X Yosemite 10.10.3 and Mail 8.2.

There is an updated version of the plugin. Not sure if Clive Galeni updated all of his download-links accordingly. Nonetheless, there is a link to the updated post in the link I've posted.

2
  • Just tried it under OS X 10.10.4 and Mail 8.2, does not work unfortunately.
    – DaPhil
    Commented May 26, 2015 at 12:30
  • I just installed the plugin on another machine and, unfortunately, it had no effect on the inline attachment. As it uses the identical versions of software I'm not sure about the reasons for this behaviour.
    – Mattheus
    Commented Jun 2, 2015 at 13:04
1

As far as I know, neither the terminal command nor the corresponding option in Tinker Tool work any longer, but I found Attachment Tamer that should be able to fix the situation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .