2

I am told, about a zip archive I created under Mavericks from the Finder File menu, with a directory containing both pdf and text files: "No file is labelled as text by zipinfo". People ask me to use a zipper able to do that. I went through the entire option list as described on the apple developer site and do not seem to find the correct invocation, if any.

I have zipinfo installed from fink, and indeed when I run it in verbose mode on the archive it says for each file "apparent file type: binary".

Is there anyway using the /usr/bin/zip shipped with Mac OS X to create archives with some text files identified as such, from the point of view of zipinfo?

  • Please move that update into an answer so your question does not come up as unanswered. – Tony Williams Jan 21 '14 at 23:29
  • Great solution. Please do take Tony's advice and answer your own question. The site works much better that way. Welcome to Ask Different! – bmike Jan 22 '14 at 0:02
3

UPDATE: well, perhaps I should have tried first, but in a test I just made, if I actually run the zip command in Terminal, then the produced archive does correctly label text files as such, as reported by zipinfo. If however I select the files in a Finder window and select the command in the Finder File menu to create an archive, then the said text files are labelled as binary file, as reported by zipinfo. It thus appears my only sin was to have used the GUI rather than the command line.

You must log in to answer this question.