2

In the Apple TV, when enabling AirPlay it shows "step 1: connect to a wifi network".

What if I have Ethernet? Bluetooth?

Will only WiFi work?

1

If you turn on the ATV's "Conference Room Display" mode (and your ATV is connected via Wi-Fi), ATV shows this text with the screensaver:

AirPlay

Wirelessly send what's on your iOS device or computer to this display using AirPlay. To learn more, go to apple.com/airplay.

1 Choose Wi-Fi Network (insert name of your network here)

2 Choose this Apple TV (insert name of your ATV here)

Based on this, it correctly explains that you can send content from iOS to ATV over Wi-Fi. It incorrectly implies that you can ONLY send content from a computer over wi-fi. This isn't true. My Mac is connected to my router via Ethernet, and the router connects to ATV over wi-fi. So, I don't actually have to do step #1 (select the wi-fi network) on my Mac, but I do need to do that on iOS.

If your ATV was connected via Ethernet, I'm sure you'd get a similar message, although it might not explicitly state which wi-fi network to use on your iOS device, since the ATV itself wouldn't be connected via wi-fi.

As long as your iOS's wi-fi network was connected to the ATV's Ethernet network "locally", it will still work. In a complex network, like in large corporation/office environment, you might not be able to get from the iOS's wi-fi to the ATV's Ethernet thru AirPlay, which might not auto-detect AirPlay devices through the various switches/routers/etc. But, in most home networks, you should be all set!

1

To switch back to a wired connection, connect the Ethernet cable. Apple TV will switch to the wired connection automatically. Apple TV prioritizes a wired Ethernet connection.

According to Apple

  • I understand that AppleTV works with Ethernet - but the question is more specific to AirPlay mirroring. – nute Jan 22 '14 at 8:44
  • @nute you might want to improve your question? As I couldn't see that anywhere. – Rob Jan 22 '14 at 8:47
  • The title and the content specifically talk about AirPlay – nute Feb 1 '14 at 18:09
1

There is another workaround, if your ATV is latest version 6.1 software updated, and iOS devices 7.1 updated, enabling Bluetooth on both ATV and iOS devices will solve this problem.

It is enabled by Bonjour over Bluetooth functionality. Then if all devices are on same network (or even if on different subnets but routable subnets) will function Airplay even if ATV is on ethernet and iOS devices are on WiFi.

Thanks to this information http://www.afp548.com/2014/03/10/hidden-airplay-feature-in-the-appletv-6-1-ios-7-1-update/

0

Airplay won't work if ATV is connected via ethernet, and iOS-OSX devices are connected via wifi even if they are on the same network.

Disabling IPv6 on OSX devices works around this problem. But since it is not possible to do this trick on iOS devices, the only solution seems to be ATV to be connected via wifi.

This limitation only applies for AirPlay. Other functionality of ATV will work the same way (i.e. sahe an iTunes library etc.) even if the ATV is connected via ethernet and other iOS-OSX devices are either on ethernet or wifi.

  • 1
    Works very well here though (ATV on LAN, iOS via WiFi) so there might be another problem with your setup. – nohillside May 14 '14 at 11:58
  • I can confirm this from my experience. My Marantz NR1504 receiver is connected via Ethernet cable and visible only to devices also connected via Ethernet (not wi-fi). If my MacBook is on Ethernet, it sees the Marantz, if it's on Wi-fi - it doesn't. Wi-Fi and Ethernet is the same network. – Ivan Nikitin Dec 30 '15 at 15:15
  • Figured out. To make AirPlay work when one device is connected via Ethernet and another via Wi-Fi, you should have WMM setting be turned OFF on your router. – Ivan Nikitin Dec 30 '15 at 15:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .