2

I have a smart mailbox setup to combine the inboxes of my 3 Gmail accounts. It worked great in 10.8. In Mavericks, this "smart inbox" frequently shows messages which have already been archived, and do not appear in the regular Gmail inbox within Mail.app. This screenshot shows an example. So Mail recognizes that the two messages are archived, yet they still show up here. These two messages do no appear in the regular Gmail inbox within Mail.

I have already tried deleting and recreating the smart mailbox. I show its settings below.

enter image description here

enter image description here

  • Has anyone followed up on this? Did you try rebooting? – Nohl Nov 24 '14 at 5:31
1

Here are two more possible solutions.

Reset Permissions

chmod -a 'everyone deny write,delete,append,writeattr,writeextattr,chown' ~/Library/Mobile\ Documents/com~apple~mail/Data/MailData/* ~/Library/Mobile\ Documents/com~apple~mail/Data/MailData/Signatures/*

This resets permissions on email related items (you can reset permissions on everything in Disk Utility).

Remove Indexes

rm -rf ~/Library/Mail/V2/MailData/Envelope*
mdimport ~/Library/Mail

This second possibility gets rid of Mail's index (Mail will rebuild it upon restart) and refreshes Spotlight with your email content.

-1

Have you tried a rebuild of the mailboxes in question?

In the Mailboxes list select your Inbox and then select Mailbox > Rebuild then do the same with the Gmail (All Mail) mailbox.

Rebuilding the Gmail mailboxes may take some time.

I would then quit Mail and restart.

  • 1
    I've rebuilt the inbox multiple times, but haven't tried rebuilding the All Mail nor the smart mailbox. I will try. – Elliott Jan 21 '14 at 4:36
  • Rebuilding did not fix the problem. – Elliott Jan 22 '14 at 1:45
-1

I had the same problem with Yosemite 10.10.1 and rebooting solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .