Today we could not get one of our machines running with 10.9 and RAID 0 which stripes the data on the boot volume.

After several hours of doing the 'standard' tasks like fixing permissions etc, we've hit a dead end for troubleshooting.

Here's what's going on:

Machine starts, we can see the apple logo and the spinning wheel / activity indicator animation. Nothing else happens.

Running safe boot mode ends in the same state.

So I have tried running verbose, the last line is:

Executing fsck_hfs (version hfs-226.1.1)

If I do a hard shutdown and start the verbose mode again, I can see in logs (last lines)

Executing fsck_hfs...
hfs: Removed 0 orphaned / unlinked files and 4 directories

I have started the system in single user mode. I ran the fsck on it, it worked just as expected:

fsck -fyd 

I've retried it twice before I got a note saying that file system is ok.

Reboot: same issue.

I can access all of the files and stuff on the raid when in single user mode, but there's no way the system will boot.

I woud love to hear some opinions, please limit the answers/comments to system tools or free tools available on the internet. Also, there's no way I'm going to remove the drives and attach to another system.

  • same problem for me, mac mini, i tried everything of you post, did you have fixed the problem? – user68948 Jan 29 '14 at 14:19
  • sorry Dario, had to reinstall the system. – Krystian Jan 29 '14 at 14:59

When you use Apple software to stripe the two internal drives of a Mac Mini, the recovery hard disk is removed. That means you will need to boot from a next journal drive to run Disk Utility and figure out what happened to the volume structure.

Fast SDHC cards are getting so inexpensive that I pretty much make one of those for every Mac Mini so it has a recovery OS to boot from for maintenance like this. Of course a USB drive works well too.

Get yourself a new drive and worst case, use internet recovery to install the OS on to an external drive so you have something to boot from. If you have a backup, you could wipe the two drives and run internet recovery as well to just fix or reinstall the OS on the empty drives.

  • hi bmike. I was able to get and diagnose the disks and system. there was nothing wrong with it. Internet recovery allows you to get to disk util/console etc. There was nothing wrong with it, still it would not boot. In the end I had to reinstall the system. that suxx. – Krystian Jan 29 '14 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .