2

I have the late 2013 model Macbook Pro retina, and a Bose Sound Link speaker (bluetooth speaker).

I am using Bootcamp with Windows 7 Pro.

I'd like to be able to connect to my Bose speaker from the Macbook via Bluetooth, and play audio from it. But the problem is, every time it will say something such as 'driver not found' and then ask me to download a new driver. I've searched quite some time, following several guides online, but none of them seem to work.

How would I do this?

3

On my MacBook Pro 17” with Windows 7 32bit – I had only to download the: Updated Bluetooth® for Windows® software at http://www.broadcom.com/support/bluetooth/update.php this small software will do all to you, find, download and install like a miracle.

On my MacBook Pro 13” with Windows 7 64bit wasn’t that easy. Just download the above driver from the apple forum:

http://global-download.acer.com/GDFiles/Driver/Bluetooth/Bluetooth_Atheros_7.4.0.96_W7x64_A.zip?acerid=634556349384706773&Step1=NOTEBOOK&Step2=ASPIRE&Step3=ASPIRE%204830TG&OS=ALL&LC=en&BC=ACER&SC=AAP_10#_ga=1.168624617.97054721.1418479225Bluetooth_Atheros_7.4.0.96_W7x64_A.zip

After unzipping I only had to run the Bluetooth_Suite_win7.EXE file, reboot the computer and my SoundLink Mini was installed correctly!

  • The Atheros driver also worked for a mid-2012 MacBook Pro Retina 15". – Adam Erickson Oct 25 '16 at 13:35
0

It would appear that you need to update the Broadcomm Bluetooth drivers using WIDCOMM Bluetooth Software to get the speakers working under Windows 7.

You can get the driver from this page :-

http://www.broadcom.com/support/bluetooth/update.php

You might also want to try updating the firmware in your speakers. You can grab an application to do that on this page :-

http://worldwide.bose.com/downloads/en/web/bose_bluetooth_speaker_download/page.html

  • I tried the driver and got this message - puu.sh/6sB58/19ae47bf6e.jpg I'm sure the bluetooth module works. – Jesse W Jan 21 '14 at 6:07
  • So it wouldn't let you download the drivers? – Tony Williams Jan 21 '14 at 6:10
  • Well I went to the broadcom URL you provided, and downloaded it. But when I ran it, I got the message saying that it couldn't find my bluetooth chip. – Jesse W Jan 21 '14 at 6:12
  • Dang. You need to get those drivers somehow. Drop an email to support at Broadcomm maybe. Did you build the Boot Camp driver pack on that computer? Does any other BlueTooth stuff work? – Tony Williams Jan 21 '14 at 6:22
  • It works just fine for things such as tethering. Apple provided a package of drivers which I've already installed. None of them include the one for bluetooth audio as far as I know though. – Jesse W Jan 21 '14 at 6:26
0

I had a similar problem and found the solution in the following link:

https://discussions.apple.com/message/17665845#17665845

Try option 3.

I hope this helps,

MAP.

0

This worked for me, no idea why.

It's one registry entry that's needed to be changed.

Follow these steps:

  1. Open up RegEdit.exe (start, run, regedit.exe)
  2. Navigate to

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BluetoothUserService\Parameters

enter image description here

You need to change ServiceDllUnloadOnStop value to 0

When you try and change it, it will tell you that you dont have permission.

  1. Change the permissions on the regedit folder, right click here, go to Permissions:

enter image description here

  1. Then go here (to advanced)

enter image description here

  1. Change the owner to your user:

enter image description here

  1. Ok ok ok ok back to regedit.

  2. Change ServiceDllUnloadOnStop to 0

enter image description here

enter image description here

  1. Restart your machine (or restart the bluetooth services)

  2. Enjoy your QuietComfort 35 wireless headphones II

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .