3

I have two MacBooks running Emacs (both 24.3). On one of them, I get same smooth, native scrolling like I do in Chrome, Finder, or whatever, but not on the other one.

To make it work a bit better, I set up scrolling so that it only scrolls one line at a time. The proper one scrolls pixel-by-pixel, and with the acceleration I'm used to.

Both of these computers use the same set of dotfiles (which you can browse here), e.g. Emacs - including the stuff about scrolling - is configured in exactly the same way.

Not sure if it matters, but one of these MacBooks (the one that works properly) is a 15" Retina one, the other is an older (mid 2009) model.

I have tried Emacs for OSX and emacs-app from Macports, both of them have the problem.

What am I missing?

5

I still have no idea how I managed to get it working on the Retina MBP, but I found this version of Emacs which supports native scrolling, much nicer full-screen mode, and more.

1
  • 3
    For those looking in 2016 (or future) this project is still active. The repos aren't showing up correctly but they maintain the homebrew formulas which use the latest source from (as of now) bitbucket. Best to just follow instructions here to get the latest version github.com/railwaycat/homebrew-emacsmacport
    – cmp
    May 9 '16 at 20:48
0

You can customise mouse scroll according to this Wiki article [1].

However, this article seems to be a bit outdated, e.g. with Emacs version 24.5 there is no need to set mouse-wheel-follow-mouse manually, because it is enabled by default.

Personally, I have set it to (1 ((shift) . 5)), which make scroll by 1 line at a time by default, and 5 lines at a time when ⇧ Shift key is held.

[1] http://www.emacswiki.org/emacs/SmoothScrolling

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .