1

I am trying to install OS X Lion on a Macbook 4,1 which I've upgraded to 4 GB of RAM.

It should support this OS, however I cannot get my Mac to see the USB drive as a bootable option. It's a SANDISK Data traveler 16GB

So far I've tried

  • Flashing the drive initially to Mac OS Extended (Journaled)
  • Partion the drive as GUID
  • Restoring the install DMG which should according to most guides make the drive bootable

However even though the drive mounts in my OS (10.5.8) it won't show in the startup disks as a bootable option.

I've tried using two permissions reset programs, another USB stick and even reseting the NVRAM. But still no joy. Does anyone know of anything else it could be?

1

Try resetting the PRAM settings. First, restart your Mac, and before you hear the "bing" sound press option key (alt) + command + r + p, it will restart your Mac, after you hear the sound twice just plug in your USB stick and press the option button and boot from there. It worked for me. Hope this helped you out.

0

Have you "blessed" the drive?

In the terminal try

sudo bless --folder /Volumes/<drivename>/System/Library/CoreServices

(replacing with the name of your drive) It should now appear in the list of bootable drives.

If that doesn't work try setting it as the boot device by hand and see what happens.

sudo bless --mount /Volumes/<drivename> --setBoot --nextonly

Then your Mac will attempt to boot off the drive on the next reboot.

  • When I try this in terminal it asks me for my password, but only gives me a few seconds to type it. Even when it is correct it still says that is incorrect? Really weird. Thanks though! – user67935 Jan 19 '14 at 23:57
  • Yes, it will ask you for your password. Are you sure you typed it correctly as the login password for your Mac should work here. – Tony Williams Jan 20 '14 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .