0

My problem is that my iPad is not recognized by my MacBook. Other iOS devices are recognised normally by the very same MacBook. The iPad charges, but nothing else works.

My specifications are the following:

  • iPad 1st generation (firmware 5.1.1) & jailbroken
  • MacBook Pro Mid-2012 (firmware 10.9.1)
  • iTunes 11.1.3

I have tried the following solutions:

It should be noted that the same issue occurs using other Macs or PCs. So my guess would be that the Jailbreak corrupted some essential files for syncing?!


EDIT 1

This is an edit in response to bmike's comment. The System Profiler shows me these settings.

enter image description here


EDIT 2

Kovah mentioned that the version of iTunes could be the issue. I have downgraded my iTunes to version 9.2.1 and did not solve the issue.


  • When you say "not recognized" do you mean the USB device doesn't show at all in System Profiler under the hardware information? Also, do third party iOS storage utilities like PhoneView see the attached storage? – bmike Jan 19 '14 at 15:20
  • @bmike No, third party iOS utilities do not see the attached storage. PhoneView says No Device Connected. – fsimkovic Jan 19 '14 at 15:29
  • Speculation, but have you tried cleaning the connector? it could be that the data wires require some attention physically. – stuffe Jan 21 '14 at 16:26
  • @stuffe I have tried that. Used different USB cables, too. Everything works fine for my iPhone, it's literally only the data transfer for the iPad. – fsimkovic Jan 21 '14 at 16:32
  • What Cydia tweaks did you install? – Rob Jan 28 '14 at 7:25
0
+50

We had some customers in our store with similar problems. Mainly they came with an iPhone 2 / 3 and asked for help because their Macs won't recognize them. Some (not all devices!) worked on an older Mac with OSX < 10.7 and a lower iTunes version. If you have a friend or family member with an older Mac try to connect to this one.
If it's not working I would say the iPad is "bricked".

  • From your experience, is it the Mac OS or the version of iTunes that is responsible for this issue?? – fsimkovic Jan 21 '14 at 17:52
  • I have no idea but since iTunes is not supporting some older devices because of the old iOS, iTunes could be the problem. – Kovah Jan 21 '14 at 17:54
  • Sometimes it can be a weird combo of both. I have seen it when downgrading the iTunes has made iphone and ipad show up and I have also seen it when trying a different version of the OS with the same iTunes has made it show it. – biw Jan 21 '14 at 18:07
  • Hm...well I will give the downgraded version of iTunes definitely a go but surely this cannot be the solution?! It would suggest everyone with a newer MacBook and and iPad 1 cannot sync the two anymore. – fsimkovic Jan 21 '14 at 18:10
0

First, you should never reset all content and settings on a jailbroken device (trust me. I did it before. I had to restore it). All it will accomplish is get your device in trouble.

So, what jailbreak did you use? Try restoring it to stock 5.1.1 firmware and see what happens. Then jailbreak it with redsn0w if everything is OK. Follow the tutorial here: http://www.iphonehacks.com/2012/06/jailbreak-ios-5-1-1-new-ipad-3-ipad-2-ipad-1-users-redsn0w-untethered.html

If that turns out OK, then slowly install your tweaks, one by one.

  • I do want to restore my device in general. I want to pass it on to a friend but in a working condition, not like it is now, i.e. without sync functionality. "Try restoring it"....Difficult if no computer recognises it. – fsimkovic Jan 23 '14 at 14:28
0

Have you tried your iPad in another computer - maybe friends PC/Mac? Don't sync as this can erase your iPad, but it would show if the other machine can see your iPad. This would then help you understand if the problem lies with the iPad or your Mac. Good luck!

  • As stated in my description of the problem, I have indeed tried other computers and no success. – fsimkovic Jan 23 '14 at 14:26
-1

Taken from this Apple Support Article : http://support.apple.com/kb/ts1591

Follow these steps to resolve your issue:

Ensure that your Mac meets the minimum system requirements for your iPhone, iPad, or iPod touch.

Install software updates on your Mac.

Note: If an iTunes update is available, apply the update.

Check USB connections. iOS devices require USB 2.0 to function properly. If you're not sure your Mac has USB 2.0 ports, refer to the computer's specifications.

Disconnect other USB devices and connect your device directly to a USB port on your Mac.

Restart your Mac.

  • AS mentioned in my original post, I have already tried this! – fsimkovic Jan 27 '14 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .